logitelnet.socgen.com - Société Générale bank denies Mozilla and Netscape 6

RESOLVED FIXED in Apr

Status

Tech Evangelism Graveyard
French
P1
major
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Tristan Nitot, Assigned: Tristan Nitot)

Tracking

unspecified
x86
Windows 2000
Dependency tree / graph

Details

(Whiteboard: [DENY] [BANK][havecontact], URL)

(Assignee)

Description

16 years ago
contact information : logitel.net@socgen.com
(Assignee)

Comment 1

16 years ago
Setting P1.
phone contact : 0.825.32.7000 (0,98 F TTC/min.), du lundi au samedi, de 8h 00 à
20h 00.
Steps to reproduce : 

1 - visit http://logitelnet.socgen.com/
2 - click on the round "Acces abonnés" button
3 - you are taken to http://logitelnet.socgen.com/navig00.html which says
roughly : "the browser you are using cannot be used to access logitelnet"

expected result : accessing the login page.

Contacted the Helpdesk. Someone is supposed to call me back. Accepting bug.

They have given me an additionnal e-mail address : contacts.particuliers@socgen.com


Status: NEW → ASSIGNED
Priority: -- → P1

Comment 2

16 years ago
bug 107110 is a dupe of this one.

Comment 3

16 years ago
*** Bug 107110 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
The bank told me to use https://logitelnet.socgen.com/accesi/ia10.html which
allows to go a bit further (and which completely worked in the past) but now the
main account can't be accessed because of the use of non-standard layer elements.

Comment 5

16 years ago
it's crazy ! they've turned their site, which used to work in Mozilla & Netscape
6, into a completely Netscape-4-dependant site ! they're moving backward in time...

Comment 6

16 years ago
*** Bug 123861 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 124594
(Assignee)

Comment 7

16 years ago
Found another contact info:
logitel.net@socgen.com

Vincent : can you confirm that there is indeed a problem with 
https://logitelnet.socgen.com/accesi/ia10.html ?

I have no account at Société Generale, so I have to rely on you. thanks.
Hello Tristan,

I just tried connecting to https://logitelnet.socgen.com/accesi/ia10.html

and it works fine. The only problem is that the server sends pages with NS4
proprietary code (with <layer> tags) which makes the site rather useless to mozilla.

Pascal

Comment 9

16 years ago
Here under Linux (whether x86 or PPC) the "COMPTE COURANT" part (main account)
does NOT work. The other accounts seem to work.

Comment 10

16 years ago
You need an account at societé generale to see the 

When you access via: https://logitelnet.socgen.com/accesi/ia10.html
you cant see the details of your account (click on "Detail de la presentation"

This is because they're using layer tag in this page
(Assignee)

Comment 11

16 years ago
Sent hand-crafter letter to logitel.net@socgen.com and
contacts.particuliers@socgen.com

waiing for answer. Target->March
Target Milestone: --- → Mar
(Assignee)

Comment 12

16 years ago
Met with Société Générale's project manager, Steve Peguet. They are considering
Netscape 6.x support later on. I encouraged them to also support Mozilla and all
gecko-based browsers. We will meet again to work on it.
Test account should be available next week, so we can see how much redesign
their site needs.
(removing critical severity : P1 do not need this.)
Severity: critical → normal
(Assignee)

Comment 13

16 years ago
Their new demo site is now open.
To start the demo : visit https://logitelnet.socgen.com/demo/demo20c.html
Click on "ommencer la demo" (start demo)
Click on the bottom left button labeled "Vos comptes" (your accounts)
click on "compte courant" (main account) in the table. 
In the table, on the center of the page, click on "Virement" link, dated 18/03/2002.
=>nothing happens

So far, this is the only broken feature I've found here. Could Mat, Pascal or
anyone have a look on this ? I have a good contact at the bank, and would like
to propose them with a workaround.

Adding mat@dioxine.com in the CC: field.

Comment 14

16 years ago
Same problem. Perhaps they should use the title attribute instead of JavaScript.
*** Bug 137184 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
The main problem is still present on the demo :
The layers are still present on the account details => the last operations are
still invisible (for "compte courant") or at the wrong place ("codevi").
I will start working on this bug in a few days... stay tuned :)

Comment 18

16 years ago
*** Bug 139706 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: logitelnet.socgen.com : bank denies Mozilla and Netscape 6 → logitelnet.socgen.com : Société Générale bank denies Mozilla and Netscape 6

Comment 19

16 years ago
*** Bug 154445 has been marked as a duplicate of this bug. ***
adding [BANK] and [DENY] to the status. Tristan, Shouldn't severity be set to
Major since gecko users can't access their bank account ?
Whiteboard: [DENY] [BANK]
(Assignee)

Comment 21

15 years ago
Setting severity to major, per Pascal's recommandation. 
Severity: normal → major
(Assignee)

Comment 22

15 years ago
See also http://bugscape.mcom.com/show_bug.cgi?id=20842
(Assignee)

Comment 23

15 years ago
Asked Linux users to write to their banks. see
http://linuxfr.org/2002/10/30/10158.html (in french). Many people CCed me in
contacting Société Générale. hopefully, they'll move on this issue.
(Assignee)

Comment 24

15 years ago
Got Alain Rey on the phone, and a confirmation e-mail message from him.
basically, it's good news :

1 - They want to support W3C standards.
2 - They have allocated a budget for this
3 - deployment of another version of their huge application is scheduled
somewhere in 2003.

Alain Rey wrote : "Suite à nos entretiens téléphoniques, je vous confirme que
nous prévoyons la compatibilité W3C de LogitelNet dans le courant de l'année 2003."
Target Milestone: Mar → Apr
Note were there attitude is full of bullsh*t is that when you click on the
printer icon (I'm using Chimera on MacOS X 10.2, but I think it does work on
Galeon on my Linux box too), you get a popup to open with the complete list of
bank operations, INCLUDING the details. Much more convenient, and you can use a
huge screen area if you wish. This is a WORKAROUND, and I don't see why I did
not think about it sooner.

For the story, I started using the service back in 1999. At that time, they
required you to use an insecure Java Applet to provide 128 bits encryption
(instead of using standard SSL). Beside that, everything was working fine. After
that they switched to SSL 128 bits, and it worked fine, including in Mozilla.
Then after they switch to their unconveniant-and-ultra-small view that use layer
and some other crap, proof of a bad design. They regressed with compatibility
and with human interface and that give the issues described in that bug.
It should be noted that since the begining they where doing that stupid access
check on the user agent, but before the layout change, the tech support robot
was providing the direct URL to access it.

Updated

15 years ago
Blocks: 186784
Masquerading User-Agent as IE works a little better. In short, it looks like
Mozilla handles better IE designed JavaScript than Netscape's 4....

I added that to the prefs.js file
user_pref("general.useragent.override", "Mozilla/5.0 (compatible; MSIE5.5;
Windows 98;");

Still fails largely, but not on the same stuff and not as badly.
Summary: logitelnet.socgen.com : Société Générale bank denies Mozilla and Netscape 6 → logitelnet.socgen.com - Société Générale bank denies Mozilla and Netscape 6

Comment 27

15 years ago
Looks like they changed something : the "Accounts" page is working.
The "Virements" still use layers and isn't working.

Comment 28

15 years ago
"Virement" is working too today. Well, the Société Générale seems to solve the
bug itself ;-) The site works well. I wonder if we should set this bug as
resolved, as no test can be performed now...
They sill reject Mozilla browsers upon entrance. Don't close the issue unless
THAT problem is solved too. (just my .02 EUR)
New Component
Component: Europe: West → French

Updated

15 years ago
Whiteboard: [DENY] [BANK] → [DENY] [BANK][havecontact]

Comment 31

15 years ago
according to comments (in french) on http://linuxfr.org/2003/07/11/13215.html
it's working fine, can we mark it fixed or do you still have remaining issues as
noted on comment 28 ?
(Assignee)

Comment 32

15 years ago
According to
http://par.societegenerale.fr/EIP/resources/production/configuration_securite/
the configuration needed to use the service includes Netscape 6.2/7 and Moz 1.0.1+

Marking resolved fixed. The whole site has been revamped to support
Standards-compliant browsers
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 33

15 years ago
socgen.com aime Mozilla :)
http://standblog.com/index.php?m=200307#p93112929
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.