Failure during add-on submission process can lead to orphaned add-on listings

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: jorgev, Assigned: kumar)

Tracking

Details

(Whiteboard: [ReviewTeam:P2][qa-])

(Reporter)

Description

4 years ago
Every now and then we get requests to fix add-on listings because something failed during the upload process and developers end up in a state where:

* The can't continue with the previous submission process.
* If they try start over, the listing and ID are already there in an Incomplete state, but not linked to their account, so they get a duplicate ID error.

In those cases I need to manually set the owner so they can submit a new version.

We need to make sure that the add-on ID and owner are linked to the listing at the same time.

Updated

4 years ago
Whiteboard: [ReviewTeam] → [ReviewTeam:P2]
Comment hidden (off-topic)
(Reporter)

Comment 2

3 years ago
(In reply to muthusmkmtp from comment #1)
> Hi !! My addon has been reviewed by AMO editors and rejected with a reason 

This is not the right place to post this. Please reply to the review email you received with any questions or objections you have about your review.
Sorry this took so long to fix. I only just saw the bug.

I'm sure there are many examples of what triggered this, but here's one example: https://github.com/mozilla/olympia/issues/1140#issuecomment-166728840

Fixed in https://github.com/mozilla/olympia/pull/1141
Assignee: nobody → kumar.mcmillan
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Adding qa- because there's no easy way to reproduce an error during submission.
Whiteboard: [ReviewTeam:P2] → [ReviewTeam:P2][qa-]
The way I tested this was to raise an exception here https://github.com/mozilla/olympia/blob/master/apps/versions/models.py#L150 then I tried to submit the add-on again without raising an exception. I was able to reproduce the orphaned state ('duplicate add-on ID') before my patch.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.