Closed Bug 1119350 Opened 5 years ago Closed 5 years ago

Virtualenv 12.0.2 not working when pypi.python.org is unavailable

Categories

(Firefox Build System :: General, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla37

People

(Reporter: toonetown, Assigned: toonetown)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/600.3.14 (KHTML, like Gecko) Version/8.0.3 Safari/600.3.14

Steps to reproduce:

Building Firefox for Android on OS X without access to pypi.python.org.


Actual results:

If pypi.python.org is unavailable during the setup of virtualenv, it will just hang.  This is due to the fact that pip is trying to get its latest version.



Expected results:

This is because virtualenv 12.0.2 embeds pip 6.0.2 (https://virtualenv.pypa.io/en/latest/changes.html) - and beginning in pip 6.0.3, when setting --no-index, it also implies --disable-pip-version-check (https://pip.pypa.io/en/latest/news.html)

I would suggest updating virtualenv to the latest version (12.0.5) which includes a fixed version of pip, as well as contains some other fixes.
Component: Untriaged → Build Config
Hardware: x86 → x86_64
This patch just updates the version of virtualenv that is used
Attachment #8546037 - Flags: review?(mh+mozilla)
Assignee: nobody → nathan
Comment on attachment 8546037 [details] [diff] [review]
bug-1119350-fix.patch

Review of attachment 8546037 [details] [diff] [review]:
-----------------------------------------------------------------

I was just about to write this patch myself :)
Attachment #8546037 - Flags: review?(mh+mozilla) → review+
QA Whiteboard: checkin-needed
QA Whiteboard: checkin-needed
Product: Firefox → Core
https://hg.mozilla.org/mozilla-central/rev/a834419aaf67
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla37
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.