[RTL][Status Bar] Icons are misaligned

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: ychung, Assigned: apastor)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(2 attachments)

Reporter

Description

5 years ago
Posted image StatusBar.png
Description:
When the device language is set to an RTL language, the icons on the status bar gets misaligned. The icons get spaced out, and the time gets shifted off the screen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Set the device language in Arabic under Settings > Language.
3) Observe the status bar.

Actual:
Icons and the time are spaced out and off the screen.
  
Expected: 
Icons on the status bar appear properly.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
Reporter

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Whiteboard: [systemsfe]
Duplicate of this bug: 1119400
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1120708
Duplicate of this bug: 1116926
Duplicate of this bug: 1059379
Seems like this is a regression, as per Stephany's comment in Bug 1059379. That former bug is a dupe of this one, but had been marked as Resolved-Worksforme on 2.2. Thus putting on regression keyword.
Keywords: regression
I confirm this issue also reproduces on latest Master, Flame device:
Gaia-Rev        9946a490a9264b42e65385d703b28fa055ab2d42
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67257a3edeb5
Build-ID        20150113160228
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  40
FW-Date         Tue Oct 21 15:59:42 CST 2014
Bootloader      L1TC10011880
Depends on: 1121748
blocking-b2g: --- → 2.2?
Not blocking on RTL bugs.
blocking-b2g: 2.2? → ---
Decided during triage this morning that this bug would in fact block on 2.2
blocking-b2g: --- → 2.2?
This also was brought to 3.0 build.
We aren't blocking RTL bugs on 2.2. But leaving decision for uplift to rel mgmt and sheriff approval. :bajaj please advise if this is your same understanding. Thanks!
blocking-b2g: 2.2? → ---
Flags: needinfo?(bbajaj)
Priority: -- → P1
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
feature-b2g: --- → 2.2+
Assignee

Comment 12

4 years ago
I saw this at some point, but can't repro anymore. Adding qawanted to double check. Note that they used to be misaligned only when the collapsed rocketbar was present.
Assignee: nobody → apastor
blocking-b2g: --- → 2.2?
Keywords: qawanted
Tracking as feature.
blocking-b2g: 2.2? → ---
QA Contact: bzumwalt
Issue still occurs on latest Flame 3.0

When user switches language to Arabic from English, status bar icons are misaligned and overlapping.

Device: Flame 3.0 Master
Build ID: 20150129010239
Gaia: 9d2378a9ef092ab1fc15c3a9f7fc4171aab59d57
Gecko: 6bfc0e1c4b29
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Issue does NOT appear to occur anymore on Flame 2.2

Even with 7 icons present in status bar (collapsed or no), the icons do not overlap each other at any time. 

Device: Flame 2.2
Build ID: 20150129003432
Gaia: 6e494f1d2676d231abba7dcc2e2822d1170d2d02
Gecko: 5e6fac01a72f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: qawanted
Can someone please verify this again on 2.2? I'm on the latest 2.2 build and I still see this issue
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Flags: needinfo?(bbajaj)
(In reply to Delphine Lebédel [:delphine - use need info] from comment #15)
> Can someone please verify this again on 2.2? I'm on the latest 2.2 build and
> I still see this issue

Happily resolved on 2.2 :)
Assignee

Comment 17

4 years ago
I cannot repro neither with 2.2. I investigated it a little bit, and it seems that the problem is only with the icons with variable width (time and connections). The weird thing is that, when opening the inspector, and changing any css (disabling and reenabling any property of that element is enough), everything goes back to normal. It sounds like a platform bug to me. Anyway, can we close it if is not happening anymore?
Flags: needinfo?(ychung)
(In reply to Alberto Pastor [:albertopq] !! PTO till Feb 23rd from comment #17)
> I cannot repro neither with 2.2. I investigated it a little bit, and it
> seems that the problem is only with the icons with variable width (time and
> connections). The weird thing is that, when opening the inspector, and
> changing any css (disabling and reenabling any property of that element is
> enough), everything goes back to normal. It sounds like a platform bug to
> me. Anyway, can we close it if is not happening anymore?

It is indeed a platform bug, see bug 1121748, the issue has been backed out for 2.2 but will go through further investigation for 3.0, we can't close this until we're sure it's fixed for master too :)
Reporter

Comment 19

4 years ago
I do not see this issue reproducing anymore on Flame 2.2. 

Result: The status bar icons are displayed properly.

Device: Flame 2.2 (319mb, full flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
===============================================

This issue STILL reproduces on Flame Master. 

Result: When the user navigates around Settings after changing the language to Arabic, the status bar icons are spaced out and mal-aligned. 

Device: Flame Master (319mb, full flash)
Build ID: 20150202010229
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 940118b1adcd
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Flags: needinfo?(ychung)

Comment 20

4 years ago
Issue continues on Flame v3.0 (Master build)
This is occurring on the 2.2 nightly for the flame

appid   	{3c2e2abc-06d4-11e1-ac3b-374f68613e61}
apptype  	b2g
vendor  	Mozilla
name    	B2G
version	2.2.0.0-prerelease
appbuildid	20150204002509
platformbuildid	20150204002509
platformversion	37.0a2
geckobuildid	20150204002509
geckoversion	37.0a2
changeset	8669c26fd4a5
locale   	en-US
os      	B2G
hardware	qcom
processor	arm
compiler	eabi
channel 	nightly-b2g37

Comment 22

4 years ago
Issue continues on Flame v3.0 

Gaia-Rev        dfebaaa8aab43470f482d09d71137bab840c3ae9
Gecko-Rev       
Build-ID        20150204010225
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880

[Added Info]
(In reply to charja13 from comment #21)
> This is occurring on the 2.2 nightly for the flame
> 
> appid   	{3c2e2abc-06d4-11e1-ac3b-374f68613e61}
> apptype  	b2g
> vendor  	Mozilla
> name    	B2G
> version	2.2.0.0-prerelease
> appbuildid	20150204002509
> platformbuildid	20150204002509
> platformversion	37.0a2
> geckobuildid	20150204002509
> geckoversion	37.0a2
> changeset	8669c26fd4a5
> locale   	en-US
> os      	B2G
> hardware	qcom
> processor	arm
> compiler	eabi
> channel 	nightly-b2g37

Please make sure you're using a proper v2.2 build and that it's the very latest. I have re checked this and it is not occurring, if you still see something wrong please include a screenshot of the issue.
Posted image icons
this is what is occurring, If you looked at the specs given the build ID is from today. I could not get any more up to date.
(In reply to charja13 from comment #24)
> Created attachment 8559410 [details]
> icons
> 
> this is what is occurring, If you looked at the specs given the build ID is
> from today. I could not get any more up to date.

Seems like an old gaia version, the original issue of this bug has been fixed, if you look at the icons order, you'll see it's correct, though the misaligned date was a bug but has been solved in a previous patch, please make sure your gaia is also the latest.
Thanks!
I am not sure what you mean, I have the 188 base image, with the shallow flash of nightly 2.2, havent been able to compile the 2.2 base image myself... need more hdd space
When you do a shallow flash make sure to flash the gaia.zip file with it.
Gaia is the user interface layer in Firefox OS, you'll need it updated to see the UI changes.

the command (on Linux) to flash both gecko and gaia should look like
./shallow_flash.sh -Gb2g-37.0a2.en-US.android-arm.tar.gz -ggaia.zip
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #27)
> When you do a shallow flash make sure to flash the gaia.zip file with it.
> Gaia is the user interface layer in Firefox OS, you'll need it updated to
> see the UI changes.
> 
> the command (on Linux) to flash both gecko and gaia should look like
> ./shallow_flash.sh -Gb2g-37.0a2.en-US.android-arm.tar.gz -ggaia.zip

okay, that is already how I had my device set up, but I went through it again with the latest nightly, 
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g37_v2_2-flame-kk-eng/ 
is the direct link to where I got the parts. Im not sure if i am doing something wrong or what, I ran the command ./shallow_flash.sh --gaia=gaia.zip --gecko=b2g-37.0a2.en-US.android-arm.tar.gz
it went through and did the shallow flash and still I am having this happen. Any ideas on the solution or if this bug is still valid then...
qawanted to see if this is still happening on master now that bug 1121748 has landed.
Keywords: qawanted
Currently on 20150205 is not alegned correctly, things are still overlapping and some off of the edge of the screen, tested on 2.2 & 2.2 eng on the flame and 2.2 simulator all with current Gaia and build
I can not reproduce this issue on the latest Flame 2.2 and Flame 3.0 builds.

Results: The icons are not spread out and the time is not cut off incorrectly.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150205010209
Gaia: 2b83a6d5d1185a438b5bbd287497ac2743b501db
Gecko: 34a66aaaca81
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150205002503
Gaia: c2047a46e29696238e9b4c9caaba47736421449a
Gecko: adfba0a07e9b
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ktucker)
Keywords: qawanted
Resolution: --- → FIXED
Flags: needinfo?(ktucker)
okay, as of right now (fri 01:29) on the master 2.2 nightly the alignment seems to be correct now, gotten from 
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame-kk/ this is now also occurring correctly for me. I will say looks very nice and neat now.
(In reply to charja13 from comment #32)
> okay, as of right now (fri 01:29) on the master 2.2 nightly the alignment
> seems to be correct now, gotten from 
> http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-
> flame-kk/ this is now also occurring correctly for me. I will say looks very
> nice and neat now.

in respect to the above comment... this was a big oops for me, I did not realize that that was the current master not the 2.2 master, the 2.2 master is still not correct as of this time, sorry about that
http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g37_v2_2-flame-kk/
from that link I have gotten both the b2g and gaia and is still not displaying properly while in the notification screen. I will say if this help and has any effect on this, I am not running the 2.2 base image, I am running the 2.0 base image 188 with a shallow flash of 2.2 nightly.
(In reply to charja13 from comment #33)
> (In reply to charja13 from comment #32)
> > okay, as of right now (fri 01:29) on the master 2.2 nightly the alignment
> > seems to be correct now, gotten from 
> > http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-
> > flame-kk/ this is now also occurring correctly for me. I will say looks very
> > nice and neat now.
> 
> in respect to the above comment... this was a big oops for me, I did not
> realize that that was the current master not the 2.2 master, the 2.2 master
> is still not correct as of this time, sorry about that
> http://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-b2g37_v2_2-
> flame-kk/
> from that link I have gotten both the b2g and gaia and is still not
> displaying properly while in the notification screen. I will say if this
> help and has any effect on this, I am not running the 2.2 base image, I am
> running the 2.0 base image 188 with a shallow flash of 2.2 nightly.

Hi, thanks for your help here. If the time in the statusbar is indeed broken on the latest 2.2, please file a new bug, attach a screenshot and the gecko/gaia revisions and cc me so I can have a look. Thank you!
Target Milestone: --- → 2.2 S5 (6feb)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15554/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.