bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Flame] [2.0] wifi turns ON without user action

RESOLVED WONTFIX

Status

Firefox OS
Wifi
--
major
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: contact, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

This morning I turned ON Wifi, checked for system updates then turned Wifi back off.

I a using Flame with 2.0.0.0-pre.


Actual results:

After a few minutes, Wifi has turned back ON spontaneously.
I thought I had made a mistake so I turned it back off. But after a few minutes, it turned on again. This happened several times during the day. Then I restarted, and it was on again.
This had already happened to me several times since I own the Flame.


Expected results:

Wifi should stay off !
(Reporter)

Updated

4 years ago
Severity: normal → major
(Reporter)

Comment 1

4 years ago
After restart, I had to turn off wifi but it finally stayed off.
Summary: wifi turns ON without user action → [Flame] [2.0] wifi turns ON without user action
Keywords: qawanted
Hi EJ, do you think this is duplicated of Bug 1115234?
QA Contact: bzumwalt
I haven't been able to reproduce the issue on Flame 2.0. Could I get more details from the reporter about how they turned off WiFi? Was it from the notification tray, or through the Settings app? Did you have Cell Data enabled?

The steps I performed were to enable and connect to WiFi, then check for updates before disabling WiFi through the notification tray. I waited for several minutes, allowing the screen to power off before checking WiFi status (still disabled.) I also tried restarting the phone, but WiFi remained disabled.

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20150108000200
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: 7c7daab470fb
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(contact)
(Reporter)

Comment 4

4 years ago
Hello, those are they steps I performed (thru notifications tray). I can't reproduce neither, I can just tell it happened to me several times since I am using the phone. I will try to find out more.
Flags: needinfo?(contact)

Comment 5

5 months ago
Firefox OS is not being worked on
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.