[RTL][System] Power menu is blank.

RESOLVED DUPLICATE of bug 1121748

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED DUPLICATE of bug 1121748
3 years ago
3 years ago

People

(Reporter: YeojinC, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8546047 [details]
PowerMenu.png

Description:
When the device language is set to an RTL language, the power menu appears blank except the cancel button. When the user presses the power button or the volume button, the text appears on the power menu.
   
Repro Steps:
1) Update a Flame device to BuildID: 20150108010221.
2) Set the device language in Arabic under Settings > Language.
3) Long-press the power button

Actual:
Text is missing on the menu.
  
Expected: 
The menu items are displayed properly.
  
Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Full Flash)
BuildID: 20150108010221
Gaia: d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko: 70de2960aa87
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
  
Repro frequency: 100%
See attached: screenshot
(Reporter)

Updated

3 years ago
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
Depends on: 1121748
blocking-b2g: --- → 2.2?
Priority: -- → P1
Blocking per RTL triage for 2.2
blocking-b2g: 2.2? → 2.2+
RTL update: marking required bugs as feature-b2g:2.2+ (and removing blocking flags)
blocking-b2g: 2.2+ → ---
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Fabien, per https://bugzilla.mozilla.org/show_bug.cgi?id=1121748#c0, is this a dupe?
Flags: needinfo?(fabien)
Keywords: verifyme

Comment 4

3 years ago
Hi Michael,
    This issue has been verified successfully on Flame 2.2. 
    In bug 1121748, it also said that the list is blank in power menu,so I think this issue is a dupe.Please check it.Thanks.
Reproduce rate:0/5.
Attachment:Verify_RTL_Powrkey.png

Flame 2.2 build:

Gaia-Rev        d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f7414413e3a5
Build-ID        20150201002504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150201.043120
FW-Date         Sun Feb  1 04:31:31 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact], [MGSEI-Triage+]
Flags: needinfo?(mhenretty)
Keywords: verifyme

Comment 5

3 years ago
Created attachment 8557809 [details]
Verify_RTL_Powerkey.png
(In reply to Coler from comment #4)
> Hi Michael,
>     This issue has been verified successfully on Flame 2.2. 
>     In bug 1121748, it also said that the list is blank in power menu,so I
> think this issue is a dupe.Please check it.Thanks.

I agree with your assessment. Thanks Coler!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(mhenretty)
Flags: needinfo?(fabien)
Resolution: --- → DUPLICATE
Duplicate of bug: 1121748
Let's get this verified as fixed on v3.0.
Keywords: verifyme
Target Milestone: --- → 2.2 S5 (6feb)

Comment 8

3 years ago
This issue has been veriified successfully on Flame 3.0.
Attachment:Verify_RTL_Power.png

Flame 3.0 build:

Build ID               20150209010211
Gaia Revision          0d7b35f23402c4cb29bca6b98280fec48a196dec
Gaia Date              2015-02-08 20:44:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3436787a82d0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.045655
Firmware Date          Mon Feb  9 04:57:06 EST 2015
Bootloader             L1TC000118D0
Keywords: verifyme

Comment 9

3 years ago
Created attachment 8561845 [details]
Verify_RTL_Power.png

Comment 10

3 years ago
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15859/
Flags: in-moztrap+
You need to log in before you can comment on or make changes to this bug.