Status

RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: jezdez, Assigned: jezdez)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [specification][type:bug])

(Assignee)

Description

4 years ago
What did you do?
================
Currently we use a really unfortunate mixture of magic and conventions for managing various configuration environments for Django.

We should not only make the settings be better structured but also outsource the main settings such as database and cache settings to environment variables.

What happened?
==============
We're stuck in the last decade.

What should have happened?
==========================
More factors of 12factors. I'm biased but will still push for using django-configurations for this.

Is there anything else we should know?
======================================
(Assignee)

Updated

4 years ago
Component: General → Code Cleanup
(Assignee)

Updated

4 years ago
Assignee: nobody → jezdez
(Assignee)

Updated

4 years ago
Blocks: 1057285
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1057287
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Depends on: 1147427
(Assignee)

Updated

3 years ago
Depends on: 1146915
(Assignee)

Updated

3 years ago
Depends on: 1146890
:cyliang - were you able to look at some different approaches for environment varaibles and/or settings & config values?
Flags: needinfo?(cliang)

Comment 3

3 years ago
I've had my head firmly stuck in RabbitMQLand(tm) for the past two days.  Barring any untoward emergencies, I'm hoping to sketch out a plan of attack and solicit some of the WebOps folks for feedback by the end of this week.
Flags: needinfo?(cliang)
Noting here that we are going to wait on other operational tasks (e.g., bug 1184470) before we get back into this.
See Also: → bug 1201500
(Assignee)

Comment 5

3 years ago
:fox2mike C asked me to ping you if we can put this on the priority list since we've been seeing more and more things that would simplify things for us -- including preparing for AWS. What do you think?
Flags: needinfo?(smani)
Blocks: 1110799

Comment 6

3 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/414dd2107ff5588d9f20c28b6b54389eaf0151d2
Bug 1119433 - Moved settings and URLconf into kuma namespace.

https://github.com/mozilla/kuma/commit/665bfb81571042dd9702a562da290ea300b6e485
Bug 1119433 - Added work-around settings for current deploy target.

This passes the Chief/Command remote host setting to Django via an environment
variable to be able to decide which settings to load.

https://github.com/mozilla/kuma/commit/050b95c991e82f1063b18ba747f337737617e40d
Bug 1119433 - Updated docs and Makefile to normalize test method.

https://github.com/mozilla/kuma/commit/0a91d44d96aab1f3eb38745e62b83b1fda67a39e
Bug 1119433 - Renamed requirements files for testing to better match settings file.

https://github.com/mozilla/kuma/commit/e7af9ec3f69beea77482a7c67e9c6ab973a23b73
Bug 1119433 - Update requirement file references after rebase

https://github.com/mozilla/kuma/commit/d97ec637c32336916679c89d75cbb80b784f98b6
Bug 1119433 - Reverting python vagrant

The looping didn't work for me, but also, we've only got 2 files to
install so I reverted this.

https://github.com/mozilla/kuma/commit/d593050064e16475cf2e4e42cd4bd1000b71dd87
Merge pull request #3262 from mozilla/bug1119433

Fix bug 1119433 - Refactor settings.
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

2 years ago
Flags: needinfo?(smani)
You need to log in before you can comment on or make changes to this bug.