Advanced _underline_ for special cases (TEXT -> HTML)

VERIFIED INVALID

Status

MailNews Core
Composition
--
enhancement
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: Peter Lairo, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
It was suggested in bug 74248 to file this bug which requests that the underline
characters (_underline_) also actually show received message texts as underlined
for special cases when composed as TEXT messages.

Here are some special cases that should show the text as underlined:

1. _multiple underlines_ in _one_ sentence.

2. _sentence with <other symbols> in them_

3. _sentence with [other symbols] in them_

4. _sentence with ~other symbols~ in them_

5. _sentence with "other symbols" in them_

6. _sentence with \other symbols\ in them_

7. _sentence with {other symbols} in them_

8. _sentence with other symbols? ? in them_

9. sentence with _*mixed*_ formatting code in it.

10. sentence with _mixed *formatting* code_ in it.

11. sentence with _mixed *formatting*_ code in it.

12. _sentence with /mixed formatting symbols/ in it_  <-- would be very nice [;)]

13. _sentence with numbers 12345 in them_

14. _sentence with decimal numbers 23.45 or 23,45 in them_

15. _sentence with hy-phen in them_

16. Multiline _sentence_ with _multiple underlines_ and _punctuation_. Multiline
_sentence_ with _multiple underline
s_ and _punctuation_. Multiline _sentence_
with _multiple underlines_ and _punctuation_.
(Reporter)

Comment 1

16 years ago
Oops, item 16 got messed up somehow. Here it is again:

16. Multiline _sentence_ with _multiple underlines_ and _punctuation_. Multiline
_sentence_ with _multiple underlines_ and _punctuation_. Multiline _sentence_
with _multiple underlines_ and _punctuation_.

Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Most cases you mention work already. (_underline_ doesn't work at all, which is
bug 74248, but they should work for *strong* etc.).

File a bug, if there is something actually wrong or arguable improvable.

INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 3

16 years ago
FYI: Mixed symbols like " _punktation_. " and " _*mixed*_ " don't work - this is
a safety-measure, so it doesn't trigger in unknown cases like ascii-art or smilies.
" *However, mixed /sentences/ /do/ work* - as long as there's not the punktation
in teh way. "
(Reporter)

Comment 4

16 years ago
None of the cases I mentioned work yet - they *all* involve special cases of
*underlining*!!!

Once regular underlining works, then this bug kicks in (as mentioned in the
first comment). Once that bug is fixed, *then* we can see if this bug is fixed
or not, no sooner!

Reopening and marking dependancy.
Status: RESOLVED → REOPENED
Depends on: 74248
Resolution: INVALID → ---
(Reporter)

Comment 5

16 years ago
RE comment #3 : we'll see if the mixed cases you mentioned work once bug 74248
is fixed, since the implementation might be *different* from that of other
formatting (italics and bold).
(Reporter)

Comment 6

16 years ago
If any of my test cases involve the unallowed combination with punctuation (#3),
then those (and *only* those) testcases can be disregarded.

Updated

16 years ago
No longer depends on: 74248

Comment 7

16 years ago
> since the implementation might be *different* from that of other formatting
> (italics and bold).

It isn't. The implementation is *identical*. The code is actually there already
and working, you just don't see the effects. You can see them with the
workaround I mentioned in the other bug.

> Once regular underlining works, then this bug kicks in

You ***guess*** some bugs about a feature that you never tested, and actually
file a bug report about it, and then even insist on it???

INVALID.
(Reporter)

Comment 8

16 years ago
>You ***guess*** some bugs about a feature that you never tested, 
> and actually file a bug report about it, and then even insist on it???

Hmmm, I guess you're right. Must've gotten carried away. Sorry.

Comment 9

16 years ago
ok :-)
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 10

16 years ago
vrfy.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.