Closed Bug 1119535 Opened 5 years ago Closed 5 years ago

Don't expose MSE on Windows < 7 in Firefox 37

Categories

(Core :: Audio/Video, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rillian, Unassigned)

References

(Blocks 1 open bug)

Details

We want to expose MSE for YouTube on Windows 7 and above in Firefox 36.

WinXP doesn't have an mp4 decoder we can call. YouTube should fall back to flash, but it would be cleaner to not expose MSE at all.

We've seen some buggy results from mp4 playback on Vista, so it might be safer to block that version for 36 as well.

This bug is about adding a runtime check on the windows version in mozilla::MediaSource::Enabled(), conditional on mediasource.youtubeonly.
We think we'll be ok with enabling on Vista once bug 1107889 lands, so this is just about not exposing MSE on XP (and NT if we still support that).

Marcia, can you check that tomorrow's Firefox 36 falls back properly on Windows XP?

We expect it to fall back to flash, but :cpearce saw it falling back to non-MSE HTML5 WebM when MSE was exposed but supported neither mp4 nor webm, which should be the default Firefox 36 Aurora config on WinXP.

I think either option is fine as long as playback works. mp4-in-flash will use fewer resources than vp9+webm, but YouTube has limited those to low resolutions so it will be pretty similar.

We should verify this again with each Firefox 36 beta build.
Flags: needinfo?(mozillamarcia.knous)
Keywords: verifyme
> and NT if we still support that

We do not.  We don't even support XP without SP2, as of Firefox 13.  So XPSP2 is the only thing we need to worry about here.
Flags: qe-verify+
Keywords: verifyme
I have run some You Tube scenarios in FF 36 Beta 1 (Build 1) using a Windows XP VM - Mozilla/5.0 (Windows NT 5.1; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20150112201205 CSet: 1b26127c3323

Playback seem to work okay with the videos I watched. All of the ones I watched so far have fallen back to webm and not flash.

I also plan to set up some real Win XP hardware and do some additional testing.
Flags: needinfo?(mozillamarcia.knous)
It looks like it is preferring the HTML5 player because we claim to have MSE support then falling back to WebM because we don't have MSE supported for actual codecs.
I tested this with Firefox 36 Beta 1 build2 (BuildID=20150114125146) on an actual machine with Windows XP x64 and x86. The fallback was done in both cases to non-MSE HTML5 WebM: video/webm (vp8.0, vorbis) - DASH=no.

I noticed some issues only when video was playing with "Stats for Nerds" overlayed:
- Win XP x86 - intermittent (visible) drops in frame rate were seen when "stats for nerds" was open (recovered when closing "stats for nerds")
- Win XP x64 - weird artifacts displayed over the video when "stats for nerds" was open and captions were hovered

The issues above seem intermittent. Let me know if you think we should pursue these any further.
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #5)
> I tested this with Firefox 36 Beta 1 build2 (BuildID=20150114125146) on an
> actual machine with Windows XP x64 and x86. The fallback was done in both
> cases to non-MSE HTML5 WebM: video/webm (vp8.0, vorbis) - DASH=no.
> 
> I noticed some issues only when video was playing with "Stats for Nerds"
> overlayed:
> - Win XP x86 - intermittent (visible) drops in frame rate were seen when
> "stats for nerds" was open (recovered when closing "stats for nerds")
> - Win XP x64 - weird artifacts displayed over the video when "stats for
> nerds" was open and captions were hovered
> 
> The issues above seem intermittent. Let me know if you think we should
> pursue these any further.

Florin: Thanks for testing - I will spot check on my side as well.
I tested on Windows XP 64-bit and 32-bit using Firefox 36 beta 2 build 1 (buildID: 20150120155007), and did not encounter any video/audio issues.

On both OS`s I get the same output in 'Stats for nerds':
 - Mime Type: video/webm; codecs="vp8.0, vorbis"
 - DASH: no

In comparison with Windows 7:
 - Mime Type: video/mp4; codecs="avc1.4d401e"
 - DASH: yes
Tested today with Firefox 36 Beta 3 build1 (BuildID=20150122214638) on Windows XP x64 and x86, and got the same results (expected) as in comment 5 (except less issues with Stats for Nerds open... perhaps those were caused by heavier HW load).
Tested today with Firefox 36 Beta 4 build1 (BuildID=20150126151838) on Windows XP x64 and x86, and got the same results (expected) as in comment 5. 

The frame rate drop and video artifacts were again seen especially on Win XP x86. I will further investigate to see if these issues can be reproduced consistently and also on other systems, when using non-MSE HTML5 WebM.
Tested today with Firefox 36 Beta 5 build1 (BuildID=20150129200438) on Windows XP x64 and x86, and got the same results (expected) as in comment 5. 

The frame rate drop and video artifacts were again seen and this time I took the time to further investigate and filed two follow up bugs: bug 1127858 and bug 1127879.
Tested Firefox 36 Beta 6 build 1 (buildID 20150202183609) on Windows XP 64-bit and 32-bit, and got the same results as in comment 7.

I did not encounter the bugs mentioned in comment 10: bug 1127858 and bug 1127879.
Tested today with Firefox 36 Beta 7 build1 (BuildID=20150205114429) on Windows XP x64 and x86, and this time I was served Flash... maybe because we're falling back to flash everywhere with this Beta version?

There were no issues on Win XP x86, but Flash content does NOT load in Win XP x64 anymore because of the no-admin sandbox (see bug 1130414).
Quick verification on Firefox 36 Beta 8 (BuildID=20150209164123) on Windows XP x64 and x86 showed the same results as in comment 12: Flash is served and works fine on XP x86, but does not work in XP x64 due to bug 1130414.
(In reply to Florin Mezei, QA (:FlorinMezei) from comment #13)
> Quick verification on Firefox 36 Beta 8 (BuildID=20150209164123) on Windows
> XP x64 and x86 showed the same results as in comment 12: Flash is served and
> works fine on XP x86, but does not work in XP x64 due to bug 1130414.

Flash being served everywhere is expected, as we are not shipping MSE in 36, so we requested this. For 37, though, what's requested in this bug is what we want to move forward with, i.e. MSE should be served for Vista and above, Flash for everything else, from what I understand.
Summary: Don't expose MSE on Windows < 7 in Firefox 36 → Don't expose MSE on Windows < 7 in Firefox 37
Surely this doesn't need to stay open now that Firefox 37 is out. Unlike the summary, the release notes say,
“Implemented a subset of the Media Source Extensions (MSE) API to allow native HTML5 playback on YouTube (Windows Vista or later only)”
Ralph - do we still need this bug?
Flags: needinfo?(giles)
No, we decided we didn't need to do this.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(giles)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.