Visual Hebrew text appears reversed

RESOLVED FIXED in mozilla0.9.8

Status

()

RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: xslf, Assigned: ftang)

Tracking

Trunk
mozilla0.9.8
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.6+)
Gecko/20011121
BuildID:    2001112108

Unlike previos bugs filed for mac OS, this is the exact opposite: Logical pages
appaer more or less ok, visual text appears tottally reveresed

Reproducible: Always
Steps to Reproduce:
1. go to any visual page...
2.
3.

Actual Results:  text in the words is reveresed

Expected Results:  should be OK

Comment 1

17 years ago
Created attachment 59208 [details]
(partial) screendump using Windows 2000

This is what I see, using Build ID: 2001 11 23 03 and Windows 2000.

Shoshannah: Just because I'm curious: What is the difference between
"logical pages" and "visual text" in Hebrew?

Comment 2

17 years ago
Svante, Hebrew is a right to left (RTL) language, HTML and webbrowsers weren't really designed to consider this, so the first 'support' for Hebrew (and Arabic...) was done using a format called Visual where you lay text out backwards according to how a dumb webbrowser would display each character from left to right (LTR).  Logical actually allows words and sentences to be typed into a document correctly instead of backwards.

Reporter: are you certain this bug isn't a dupe of any of them?

Comment 3

17 years ago
reporter: which mac mozilla are you using? classic, CFM or Mach-O?

there are only two live Mac OS X bidi bugs and they're both yours, does that mean you resolved bug 110655?

The fact that you're running on OS X instead of OS8/9 should probably be able to explain this reversal of BiDi support.
(Reporter)

Comment 4

17 years ago
Bug  110655 is not resolved yet, so I do not have control over the typface used
to display Hebrew sites. However, Logical hebrew sites (like tapuz.co.il or
ynet.co.il ) display more or less OK.
the search i did for mac Hebrew bugs:
http://bugzilla.mozilla.org/buglist.cgi?bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&field0-0-0=product&type0-0-0=substring&value0-0-0=hebrew&field0-0-1=component&type0-0-1=substring&value0-0-1=hebrew&field0-0-2=short_desc&type0-0-2=substring&value0-0-2=hebrew&field0-0-3=status_whiteboard&type0-0-3=substring&value0-0-3=hebrew&field1-0-0=rep_platform&type1-0-0=substring&value1-0-0=mac
brings up 8 bugs, all about logical pages, not visual.
I am not sure how to tell if I am running CFM or Mach-O Mozilla- I downloaded
this build from the latest nightly for mac OS 10 (not Classic).
I am running OS 10.1, with Hebrew fonts taken from system 9.2 and a
unicode/hebrew keyboard (avalible from
http://forums.ort.org.il/scripts/showsm.asp?which_forum=307&mess=1020363 )
On the same system, I can get OmniWeb to display visual pages, but no logical ones.

Comment 5

17 years ago
the nightlies are CFM
(Assignee)

Comment 6

17 years ago
I think fixing bug 116976 and 116982 will fix this problem 
Assignee: mkaply → ftang
Status: UNCONFIRMED → NEW
Depends on: 116976, 116982
Ever confirmed: true
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.8
(Assignee)

Comment 7

17 years ago
I believe the following three patch should fix most mac os hewbrew problem

big endian issue in nsFrame.cpp
see latest patch in http://bugzilla.mozilla.org/show_bug.cgi?id=116976

big endian issue in nsBidiImp.cpp 
http://bugzilla.mozilla.org/attachment.cgi?id=62917&action=view

turn off hebrew reordering and do not report hint on mac gfx
http://bugzilla.mozilla.org/attachment.cgi?id=62920&action=view
(Assignee)

Comment 8

17 years ago
this should be fixed right now.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Updated

17 years ago
Blocks: 104060
(Assignee)

Updated

17 years ago
No longer blocks: 104060

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.