Closed Bug 1119688 Opened 5 years ago Closed 5 years ago

[TextSelection] Calendar event view cursors not adjustable

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: twen, Assigned: mmedeiros)

References

Details

Attachments

(3 files)

### STR
0. Prerequisite: Create an event with notes in calendar  
1. Open calendar app
2. Tap on the event 
3. Long press on event notes
4. Move the right cursor to the left 

### Actual
Cursor not moving

### Expected
Cursor can be adjusted for selection

### Version
Gaia-Rev        82b534791a72ad59c78363df80459e18d35b48f8
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/d480b3542cc2
Build-ID        20150108160401
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150105.192724
FW-Date         Mon Jan  5 19:27:36 EST 2015
Bootloader      L1TC00011880
QA Whiteboard: [textselection]
Hi Teri, that would be very helpful if you can provide screenshot on the bugs you open, thank you!
Flags: needinfo?(twen)
Attached video MOV_2488.mp4
There is also the issue of automatic select all. Let me know if you want a separate bug to track it. Thanks.
Flags: needinfo?(twen)
blocking-b2g: --- → 2.2?
Assignee: nobody → mmedeiros
The automatic select all of text mentioned in comment 2 is written in bug 1126580
Attachment #8557120 - Flags: review?(gaye)
Blocks: 1120347
Blocks: CopyPasteGaia
No longer blocks: CopyPasteLegacy
Comment on attachment 8557120 [details] [review]
[PullReq] millermedeiros:1119688-text-selection to mozilla-b2g:master

Looks fine to me!
Attachment #8557120 - Flags: review?(gaye) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8557120 [details] [review]
[PullReq] millermedeiros:1119688-text-selection to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: user won't be able to set and/or cancel text selection
[Testing completed]: manual testing on flame
[Risk to taking this patch] (and alternatives if risky): very low risk, changed a single CSS selector and a single property
[String changes made]: none
Attachment #8557120 - Flags: approval-gaia-v2.2?
blocking-b2g: 2.2? → 2.2+
Attachment #8557120 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
Duplicate of this bug: 1120347
QA Whiteboard: [textselection] → [COM=Text Selection]
Attached video verify.MP4
This issue has been verified successfully on Flame 2.2/3.0
STR:
Prerequisite: Create an event with notes in calendar.
1. Open calendar app.
2. Tap on the event.
**There is no response.
3. Long press on event notes.
4. Move the right cursor to the left.
**The cursor can be adjusted for selection.
See attachment:verify.MP4
Rate:0/5

Flame 2.2 build:
Build ID               20150204162500
Gaia Revision          c2047a46e29696238e9b4c9caaba47736421449a
Gaia Date              2015-02-04 20:34:04
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/adfba0a07e9b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.195445
Firmware Date          Wed Feb  4 19:54:56 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150204010225
Gaia Revision          dfebaaa8aab43470f482d09d71137bab840c3ae9
Gaia Date              2015-02-03 18:49:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/0c2f7434c325
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.043856
Firmware Date          Wed Feb  4 04:39:07 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [COM=Text Selection] → [COM=Text Selection][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.