If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Stingray] KeyNavigationAdapter should handle both keydown and keyup event

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dwi2, Assigned: johnhu)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices][ETA:1/23])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
KeyNavigationAdapter should handle both keydown and keyup event, and fire events accordingly. Because not every smart-screen application needs keyup event, some may need keydown event.
This introduce a regression that app deck and system app receives keyboard event at the same time.
Assignee: nobody → im
I will create another issue to fix the issue at comment 1
Assignee: im → nobody
John, our partner is asking this bug, what's your plan?
Flags: needinfo?(im)

Updated

3 years ago
Blocks: 1115611
In the navigation cases, we should use keydown to have multiple keydown events fired while hold the key. But with the click case, we should use keyup to handle it.

Our plan is to extend the KeyNavigationAdapter to have extra events/arguments to tell this is keydown or keyup and use them at the correct place.

If this is high priority, I can fix it.
Flags: needinfo?(im)
Assignee: nobody → im
Please also label an ETA. Thank you!
Created attachment 8551038 [details] [review]
handle keydown/up

Rex,

Please review this patch since you are the creator of this file.
Attachment #8551038 - Flags: review?(rexboy)
Blocks: 1123172
Whiteboard: [ft:conndevices] → [ft:conndevices][ETA:1/23]
Comment on attachment 8551038 [details] [review]
handle keydown/up

Looks good to me.
I think we can add some comment to note the reason for using keyup.
Attachment #8551038 - Flags: review?(rexboy) → review+
merged to master:
https://github.com/mozilla-b2g/gaia/commit/174cc78d38ea52a3ef0a51697e42e7005bcdfef3
gaia try has two known issues.
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=e80287e15efc
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.