[Flame][Contacts] When we tap the Settings icon after launching Contacts from Phone application, there is no response.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: yulan.zhu, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8546515 [details]
logcat.txt

[1.Description]:
[Flame][v2.1][Contacts] Make a call without SIM card and tap the Contacts tab to enter the contacts list, we cannot enter Settings page when tapping the Settings icon.
Attach video:Video.mp4.
Attach logcat:logcat.txt.
Occurrence time:16:41

[2.Testing Steps]: 
Premise:There are 120 contacts in the contact list.

1.Launch Phone.
2.Make a call without SIM card.
3.Tap "ok" button in the "No network connection" page.
4.Tap the Contacts tab to enter the contacts list.
5.Tap Settings icon.

[3.Expected Result]: 
5. Device should enter contact settings view.

[4.Actual Result]: 
5.There is no response.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        ed2e278753e8c9301ba322dcf2c3591f5928408d
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/127a0ead5f83
Build-ID        20150108001214
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150108.040209
FW-Date         Thu Jan  8 04:02:21 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        d4dac29613076bdba3cb8adc217deadb08a2ac20
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/70de2960aa87
Build-ID        20150108010221
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150108.044406
FW-Date         Thu Jan  8 04:44:17 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Once,1/20

[7.TCID]:
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8546516 [details]
Video.MP4

Comment 2

4 years ago
verify with today's v2.1, cannot reproduce this issue
Gaia-Rev        64db236bea9a0510567ab7ced2f2b4688737123c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/273f24a1d1fe
Build-ID        20150111161203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.194343
FW-Date         Sun Jan 11 19:43:54 EST 2015
Bootloader      L1TC100118D0

Hi Lancy, could you help to verify it again?
Flags: needinfo?(yulan.zhu)
(Reporter)

Comment 3

4 years ago
Hi Mike,

The issue is verified not happen in latest build.

Flame 2.1 build:
Gaia-Rev        1975241ac29f723479e6c60b2bf74ebed54da91a
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0863fe4b75c3
Build-ID        20150112001215
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150112.035023
FW-Date         Mon Jan 12 03:50:34 EST 2015
Bootloader      L1TC000118D0

Change the status to WORKSFORME, if anyone can repro it, reopen again.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(yulan.zhu)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.