Closed Bug 1119796 Opened 5 years ago Closed Last year

panel.openPopup() method causes interface blink and misbehave

Categories

(Firefox for Android :: General, defect)

34 Branch
Other
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: manvel, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.71 Safari/537.36

Steps to reproduce:

Install provided testing add-on (panel-blink.xpi) on Firefox for Android.


Actual results:

The mobile screen starts to blink and misbehave.


Expected results:

The panel should be opened without screen blinking and interface shouldn't misbehave.
OS: Linux → Android
Hardware: x86_64 → Other
The reproduction addon was tested on current devices:
Nexus 4
Android: 5.0.1
Firefox version: 34.0.1 (stable), 35.0 (beta)

Nexus 7
Android: 4.4.4
Firefox version: 31.0
Blocks: abp
Hi, thank you for report. I tried to test the issue on HTC Desire 820 (Android 6.0.1) and LG G4 ( Android 6.0) on latest Nightly (63.0a1 2018-07-26) and Release (61.0) and I can't reproduce it. Due to long time from report and actual version the issue probably it's fixed. Can you please retry on latest Nightly and see if the issue it's still reproducible?  

Thanks, 
Stefan.
Flags: needinfo?(manvel)
(In reply to Stefan Deiac from comment #2)
> Hi, thank you for report. I tried to test the issue on HTC Desire 820
> (Android 6.0.1) and LG G4 ( Android 6.0) on latest Nightly (63.0a1
> 2018-07-26) and Release (61.0) and I can't reproduce it. Due to long time
> from report and actual version the issue probably it's fixed. Can you please
> retry on latest Nightly and see if the issue it's still reproducible?  
> 
> Thanks, 
> Stefan.

Yes, I'm sure that this issue was since XUL based extensions, I even can't test it properly because it's not based on WebExtensions APIs.

I think this issue can be closed. 

Thanks for heads-up, totally forgot about this issue.
Flags: needinfo?(manvel)
Due to comment 3 I will close this issue as WFM, Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.