Closed Bug 11198 Opened 21 years ago Closed 21 years ago

Crash creating, deleting or editing a card in Abook, when Abook is opened the 2nd time in one messenger session

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3, critical)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: esther, Assigned: chuang)

References

Details

Using builds 19990802 on win95, linux and mac you will crash when editing,
creating or deleting a card in the Abook in a 2nd session.

1. Launch Messenger
2. Select Address Book from Tasks menu
3. Select Personal Address Book (to display your cards, should have at least 2)
4. Close Address Book
5. Repeat steps 2&3 again
6. Select a card and click the Delete Toolbar button
This is where it crashes now.   Talkback incident logged, I will put the stack
trace in here when I get it.

Note: Any action on a card in the 2nd session of the Address Book will cause the
crash (Edit, New, Delete).
UPDATE:  Using builds today 199908023xx on Win this is still the same.  On Mac
it crashes in the 3rd opening of Abook and Linux it crashes on 1st opening
(11191).  Will keep checking with tomorrow's builds.
Target Milestone: M9
It sounds like this should be fixed for M9.
Udating again:  using build 19990804 on linux this scenario can be tested (11191
is no longer in the way)and is still a problem on this platform.  It is also
still a problem on 1999080409 win32 and mac platforms (mac is back to crashing
on 2nd launch of Abook).
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fix checked in.  Windows fine, I havn't tested on Linux and Mac.  Reopen if
happened on those two platforms.
*** Bug 11201 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
Using 19990806 build on win95 & mac this scenario as stated doesn't crash
anymore, however linux crashes a step earlier (repeating only step 2).  I will
verify this bug and log a new [PP] bug on linux.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.