Large OOM in Http2Session::TryToActivate or SpdySession31::TryToActivate

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kairo, Unassigned)

Tracking

({crash})

Trunk
All
Windows NT
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [spdy], crash signature)

This bug was filed from the Socorro interface and is 
report bp-aabcb969-bd1b-4c02-94c0-0ce1e2150107.
=============================================================

Top frames:
0 	xul.dll 	NS_ABORT_OOM(unsigned __int64) 	xpcom/base/nsDebugImpl.cpp
1 	xul.dll 	nsDeque::Push(void*) 	xpcom/glue/nsDeque.h
2 	xul.dll 	mozilla::net::Http2Session::TryToActivate(mozilla::net::Http2Stream*) 	netwerk/protocol/http/Http2Session.cpp
3 	xul.dll 	mozilla::net::Http2Stream::OnReadSegment(char const*, unsigned int, unsigned int*) 	netwerk/protocol/http/Http2Stream.cpp
4 	xul.dll 	mozilla::net::nsHttpTransaction::ReadRequestSegment(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*) 	netwerk/protocol/http/nsHttpTransaction.cpp
5 	xul.dll 	nsBufferedInputStream::ReadSegments(tag_nsresult (*)(nsIInputStream*, void*, char const*, unsigned int, unsigned int, unsigned int*), void*, unsigned int, unsigned int*) 	netwerk/base/src/nsBufferedStreams.cpp
[...]

Some stacks apparently come from SpdySession31::TryToActivate instead of Http2Session::TryToActivate.

This started on Nightly on 2015-01-07, see https://crash-stats.mozilla.com/report/list?signature=OOM%20%7C%20large%20%7C%20NS_ABORT_OOM%28unsigned%20__int64%29%20%7C%20nsDeque%3A%3APush%28void%2A%29 for more reports and stats.
Whiteboard: [spdy]
resolve this by backout of bug 1072478
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1120096
Crash Signature: [@ OOM | large | NS_ABORT_OOM(unsigned __int64) | nsDeque::Push(void*)] → [@ OOM | large | NS_ABORT_OOM(unsigned __int64) | nsDeque::Push(void*)] [@ OOM | large | NS_ABORT_OOM(unsigned int) | nsDeque::Push(void*)]
You need to log in before you can comment on or make changes to this bug.