If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Camera width/height constraints ignored on Windows (REGRESSION)

VERIFIED FIXED in Firefox 36

Status

()

Core
WebRTC: Audio/Video
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: jib, Assigned: gcp)

Tracking

34 Branch
mozilla38
All
Windows 7
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox34 wontfix, firefox35 wontfix, firefox36 verified, firefox37 verified, firefox38 verified)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 8546727 [details] [diff] [review]
undo_d26db5427e8a.patch

STR:
1. On a Windows box with an HD webcam (like Logitech C910 or higher)
2. Open URL
3. Hit [Start!] button and share the camera.

Expected result:
- Success: 1280x720

Actual result:
- Success: 640x480

Tests performed:

Windows 7 FF 32.0:  Success: 1280x720 (good)
Windows 7 FF 34.05: Success: 640x480  (bad)

mozregression only got me so far on my Windows setup:
Last good revision: 0aaa2d3d15cc
First bad revision: 111a1da2a95d

The culprit is https://hg.mozilla.org/integration/mozilla-inbound/rev/d26db5427e8a

I've attached a reverse patch of that commit and verified that it fixes this bug on my Windows 7 machine.

Thanks Florin for catching this in Bug 1094539 comment 17! I'll try to work on some automated tests so this doesn't keep breaking every few months. :-/
Blocks: 929431
(Assignee)

Comment 1

3 years ago
Ugh, let's see if we can fix the bug in that patch because regressing 929431 renders WebRTC (and by extension Loop) unusable for a lot of people.
(Assignee)

Comment 2

3 years ago
Created attachment 8547462 [details] [diff] [review]
fix-requestedcapability
Attachment #8546727 - Attachment is obsolete: true
Attachment #8547462 - Flags: review?(rjesup)
(Assignee)

Updated

3 years ago
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
status-firefox37: --- → affected

Updated

3 years ago
Attachment #8547462 - Flags: review?(rjesup) → review+
(Assignee)

Comment 3

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1bb2c1c87b4c
https://hg.mozilla.org/mozilla-central/rev/1bb2c1c87b4c
Assignee: nobody → gpascutto
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(Assignee)

Comment 5

3 years ago
Comment on attachment 8547462 [details] [diff] [review]
fix-requestedcapability

Approval Request Comment
[Feature/regressing bug #]: Bug 929431
[User impact if declined]: WebRTC width/height constraints not taken into account on Windows
[Describe test coverage new/current, TBPL]: None, landed on m-c +- week ago
[Risks and why]: Worst case some cameras with bad drivers will be slower starting a WebRTC session or break completely.
[String/UUID change made/needed]: None
Attachment #8547462 - Flags: approval-mozilla-beta?
Attachment #8547462 - Flags: approval-mozilla-aurora?
status-firefox34: affected → wontfix
status-firefox38: --- → fixed
status-firefox35: affected → wontfix
Attachment #8547462 - Flags: approval-mozilla-beta?
Attachment #8547462 - Flags: approval-mozilla-beta+
Attachment #8547462 - Flags: approval-mozilla-aurora?
Attachment #8547462 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/2f41efcb45d6
https://hg.mozilla.org/releases/mozilla-beta/rev/ee09df3331d0
status-firefox36: affected → fixed
status-firefox37: affected → fixed
Flags: qe-verify+

Comment 7

3 years ago
Reproduced on Nightly 2015-01-09, Windows 7 x64, with str from comment 0 - Success: 640x480 is displayed.
Verified as fixed on 36.0 beta 3 (Build ID: 20150122214638), Aurora 37.0a2 (Build ID: 20150125004007) and Nightly 38.0a1 (Build ID: 20150125030202) with e10s enabled/disabled.
Status: RESOLVED → VERIFIED
status-firefox36: fixed → verified
status-firefox37: fixed → verified
status-firefox38: fixed → verified
You need to log in before you can comment on or make changes to this bug.