Hitting PROVIDER_LOGOUT_FAIL

RESOLVED FIXED

Status

Marketplace
Payments/Refunds
P2
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Andy McKay, Assigned: ashort)

Tracking

Avenir
x86
Mac OS X
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When purchasing on FxOS 2.1 using the native FxA flow we hit an error: PROVIDER_LOGOUT_FAIL. When purchasing on FxOS 2.0 using the web based FxA flow it gets to the buy page without issue.

The attached video shows FxOS 2.0 and then the same flow in FxOS 2.1.
(Reporter)

Comment 1

3 years ago
Created attachment 8546730 [details]
provider-logout.mov
Whic in turn looks like it's probably caused by the email data not being set on verification - see https://github.com/mozilla/spartacus/blob/b390d0951e5594a8ebfe1d46baab04233aafb8d2/public/js/lib/auth.js#L135
Assignee: nobody → ashort
(Reporter)

Updated

3 years ago
Priority: -- → P2
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla/webpay/commit/101e07ffca7ce1428b5e083c58295266f9683597
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.