If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Recently added Track shows at bottom of the recently added music list

RESOLVED DUPLICATE of bug 1134229

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 1134229
3 years ago
3 years ago

People

(Reporter: Mahir Labib Chowdhury, Assigned: dkuo)

Tracking

({regression})

unspecified
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141231004008

Steps to reproduce:

1. Open Music App
2. Click "Playlist" button
3. Select Recently Added


Actual results:

The most recently added track is on the bottom of the list


Expected results:

The recently added track should be on the top of the list. The list should show reversed.
(Reporter)

Comment 1

3 years ago
Can you check this?
Flags: needinfo?(dkuo)

Comment 2

3 years ago
N? the UX owner, Jacqueline to verify the isuue.
Hi Jacqueline, please help to check. Thank you.
Flags: needinfo?(jsavory)
(Assignee)

Comment 3

3 years ago
(In reply to Mahir Labib Chowdhury from comment #1)
> Can you check this?

Hi Mahir, would you please describe how you add your new track and probably attach your test file here? it will be very helpful if you could add more information about this issue, which should help us to narrow down the problem quickly, thanks.
Flags: needinfo?(dkuo) → needinfo?(optical.mahir)

Comment 4

3 years ago
Dominic is working on solving the issue with Mahir based on UX spec.
Flags: needinfo?(jsavory)
(Reporter)

Comment 5

3 years ago
(In reply to Dominic Kuo [:dkuo] from comment #3)

> Hi Mahir, would you please describe how you add your new track and probably
> attach your test file here? it will be very helpful if you could add more
> information about this issue, which should help us to narrow down the
> problem quickly, thanks.

Actually I downloaded some files and transferred with Bluetooth, the same result each time.
Flags: needinfo?(optical.mahir)
(Reporter)

Comment 6

3 years ago
any update on this? I'm still having this issue on v3.0
Flags: needinfo?(dkuo)
(Assignee)

Comment 7

3 years ago
(In reply to Mahir Labib Chowdhury from comment #6)
> any update on this? I'm still having this issue on v3.0

I can reproduce this issue with master build, should be a regression, taking this.
Assignee: nobody → dkuo
blocking-b2g: --- → 2.2?
Flags: needinfo?(dkuo)
Keywords: regression
Confirming this! :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mahir, can you please let know Which build you have used to reproduce the issue? It will be help to get the Regression!
As you have filled this Bug at 9th January, so you have used any build made before 9th January. I am trying to find out the regression
Flags: needinfo?(optical.mahir)
It seems that this problem is happened for a commit landed between 6th November 2014 to 7th November 2014.

I have tested with Gaia build of 6th November but could not get reproduce it.
But, with Gaia build of 7th November, I could reproduce the issue.
so it seems that this issue is caused by any commit landed between this time frame
Oh! Got it. Only one commit landed between the Time frame. (2014-11-06 to 2014-11-07).

So I think this commit is responsible for the issue

https://github.com/mozilla-b2g/gaia/commit/ba627cf2f2fbcbb5e47be207e6411e79b2348b01

Dominic, As you have made the commit, Can you please re check why that commit is raising this issue?
Flags: needinfo?(dkuo)

Updated

3 years ago
blocking-b2g: 2.2? → 2.2+
(Reporter)

Comment 12

3 years ago
I think you've already found it :)
Flags: needinfo?(optical.mahir)
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Bahaj, it seems to be affect 2.1. is it possible to block 2.1?
Flags: needinfo?(bbajaj)
(Assignee)

Comment 14

3 years ago
(In reply to Safwan Rahman from comment #11)
> Dominic, As you have made the commit, Can you please re check why that
> commit is raising this issue?

It's a refactoring commit so caused regressions, sorry about that but thanks to Hub, he has a patch in bug 1134229 which also fixes this, I am going dup it.
Flags: needinfo?(dkuo)
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134229
(In reply to Safwan Rahman from comment #13)
> Bahaj, it seems to be affect 2.1. is it possible to block 2.1?

Hmm, given its a regression we could consider depending on risk...

:hub/hema, thoughts on getting patch in https://bugzilla.mozilla.org/show_bug.cgi?id=1134229 uplifted to 2.1 given its busted since then?
Flags: needinfo?(hub)
Flags: needinfo?(hkoka)
Flags: needinfo?(bbajaj)

Comment 17

3 years ago
(In reply to bhavana bajaj [:bajaj] from comment #16)
> (In reply to Safwan Rahman from comment #13)
> > Bahaj, it seems to be affect 2.1. is it possible to block 2.1?
> 
> Hmm, given its a regression we could consider depending on risk...
> 
> :hub/hema, thoughts on getting patch in
> https://bugzilla.mozilla.org/show_bug.cgi?id=1134229 uplifted to 2.1 given
> its busted since then?

Bajaj: Are we still landing patches to 2.1? 

Also can you get QA to verify if Hub's fix addresses this issue on master/2.2 first?

Thanks
Hema
Flags: needinfo?(hkoka) → needinfo?(bbajaj)
(In reply to Hema Koka [:hema] from comment #17)
> (In reply to bhavana bajaj [:bajaj] from comment #16)
> > (In reply to Safwan Rahman from comment #13)
> > > Bahaj, it seems to be affect 2.1. is it possible to block 2.1?
> > 
> > Hmm, given its a regression we could consider depending on risk...
> > 
> > :hub/hema, thoughts on getting patch in
> > https://bugzilla.mozilla.org/show_bug.cgi?id=1134229 uplifted to 2.1 given
> > its busted since then?
> 
> Bajaj: Are we still landing patches to 2.1? 
Serious blocking regressions with low risk are getting landed, hence wanted to check with you if you think this is one of those cases. I am on the fence but given this was requested from a dogfooder hitting this regression in 2.1, i assume this could be a common case and wanted to follow-up with you.
> 
> Also can you get QA to verify if Hub's fix addresses this issue on
> master/2.2 first?
Sure, I've requested verification.
> 
> Thanks
> Hema
Flags: needinfo?(bbajaj)
We should discuss whether we want this in 2.1 on bug 1134229 since this is were the fix lives.
Flags: needinfo?(hub)
You need to log in before you can comment on or make changes to this bug.