Loading missing local file causes screen not to repaint

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
20 years ago
2 years ago

People

(Reporter: morse, Assigned: morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

20 years ago
Go to slip/projects/marvin/wallet/login.html.  Fill in form and submit it.
Switch to another window which overlays the browser and then switch back to the
browser.  Browser repaints fine.

Now copy slip/projects/marvin/wallet/login.html onto a local file on your hard
drive.  Go to that file.  Perform the same steps as above.  When you switch back
to the browser, screen fails to repaint.

It looks like this page is calling a cgi script and when you moved the page to
the hard drive, you no longer have the script.  That's why I reported this as a
problem with a missing cgi script, but I could be totally wrong about that.

Updated

20 years ago
Summary: Missing cgi script causes screen not to repaint → Loading missing local file causes screen not to repaint

Comment 1

20 years ago
The cgi does not exist on the server or locally, actually. The difference has to
do with the errors returned, probably. On 4.5, when you call a bogus local file,
you get a little pop-up that says "Netscape is unable to find the file or
directory...". Looks like we are missing something like that in Seamonkey.

To reproduce this bug, just try to load any bogus local file, then go to another
window and come back. cc'ing warren and adjusting summary.

Updated

20 years ago
Assignee: gagan → morse

Comment 2

20 years ago
Steve, can you step through this and let us know what's going on? Thanks.
(Assignee)

Comment 3

20 years ago
Warren, we know exactly what is going on.  Paul summarized it nicely.
(Assignee)

Updated

20 years ago
Assignee: morse → warren

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M10

Comment 4

20 years ago
Steve, I mean that we would like you to try and debug the problem. The necko
team is completely overloaded at the moment, and as much as we'd like to get to
this, we're not able to at the moment. If you've got time to help out, that
would be great. Otherwise, I'm going to have to mark this for m10 or later.

Updated

20 years ago
Assignee: warren → morse
Status: ASSIGNED → NEW

Comment 5

20 years ago
I can't reproduce this. Steve, can you try it again?
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

20 years ago
Looks like it got fixed somewhere along the line because I'm not seeing the
original problem any more.  Closing this out.

However we do not get the pop-up saying "file does not exist" as Paul described.
That's true for local files as well as from across the net.  Is there already
an open bug on that or should I open one?

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 7

20 years ago
I couldn't find a bug on this. I will file it. Marking this bug verified works
for me.

Comment 8

19 years ago
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
You need to log in before you can comment on or make changes to this bug.