Closed Bug 1120020 Opened 8 years ago Closed 5 years ago

Tracking Protection breaks video.pbs.org navigation (g-a breakage)

Categories

(Web Compatibility :: Desktop, defect, P5)

x86
macOS
defect

Tracking

(firefox60 verified, firefox61 verified)

RESOLVED WORKSFORME
Tracking Status
firefox60 --- verified
firefox61 --- verified

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: reproducible, Whiteboard: tp-base)

STR:
1. Enable Tracking Protection
2. Load http://video.pbs.org/
3. Click on any of the video images

RESULT:
Nothing happens. If you disable Tracking Protection, then clicking the video images navigates to that video's page.
Summary: Tracking Protection breaks PBS → Tracking Protection breaks video.pds.org navigation
Summary: Tracking Protection breaks video.pds.org navigation → Tracking Protection breaks video.pbs.org navigation
Thanks for reporting, Chris. I looked at this and it appears that the link works fine if you right-click, but they are doing something like overloading the onclick handler with code that depends on an analytics script that we are blocking, so left-click fails. I'm not sure what we can do in this case short of allowlisting the analytics scripts.
Summary: Tracking Protection breaks video.pbs.org navigation → Tracking Protection breaks video.pbs.org navigation (g-a breakage)
The resource at "http://ad.doubleclick.net/N6735/adj/n6735.pbs/video_main;sz=728x90;ord=6873921298648954?" was blocked because tracking protection is enabled. video.pbs.org
The resource at "http://www.googletagservices.com/tag/js/gpt_mobile.js" was blocked because tracking protection is enabled. video.pbs.org
ReferenceError: googletag is not defined video.pbs.org:201:16
The resource at "http://www.google-analytics.com/ga.js" was blocked because tracking protection is enabled. video.pbs.org
The resource at "http://www.google-analytics.com/analytics.js" was blocked because tracking protection is enabled. video.pbs.org
The resource at "http://b.scorecardresearch.com/b?c1=2&c2=3005420&ns__t=1431022019495&ns_c=UTF-8&c8=Watch%20PBS%20Online%20%7C%20PBS%20Video&c7=http%3A%2F%2Fvideo.pbs.org%2F&c9=" was blocked because tracking protection is enabled. video.pbs.org
Component: DOM: Security → Safe Browsing
Product: Core → Toolkit
Component: Safe Browsing → Tracking Protection
Product: Toolkit → Firefox
Keywords: DevAdvocacy
Priority: -- → P5
Whiteboard: tp-base
Component: Tracking Protection → Desktop
Keywords: DevAdvocacy
Priority: P5 → --
Product: Firefox → Tech Evangelism
Tested on Nightly FF 58.0.a1, enabled TP, viewed http://video.pbs.org/, clicked on video and was redirected to:
http://www.pbs.org/video/we-are-the-immigrants-9dwymg/
Unable to reproduce this issue.

Chris - can you still reproduce?
Flags: needinfo?(cpeterson)
Priority: -- → P5
WFM in Firefox 59 and Nightly 61.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(cpeterson)
Resolution: --- → WORKSFORME
Blocks: tpvideo
No longer blocks: tp-breakage
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.