border-image with border-width but no border-style shows no border and has computed border-width of 0

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: marko_avlijau0161, Unassigned)

Tracking

({reproducible, testcase})

34 Branch
reproducible, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8547025 [details]
border-image.zip

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141126041045

Steps to reproduce:

Open attached html file in firefox.


Actual results:

Border image is not displayed at all.


Expected results:

Border image should have been displayed on left border of div#paper. (check in chrome).

This used to work in firefox in 2010. I know because it's an example from a book written in 2010 and author doesn't mention any problems in firefox.

Comment 1

3 years ago
Created attachment 8549727 [details]
Testcase

Updated

3 years ago
Attachment #8549727 - Attachment filename: file_1120072.txt → border-image-no-border-style.html
Attachment #8549727 - Attachment mime type: text/plain → text/html

Comment 2

3 years ago
Don't know whether this is a bug with us or with Chrome. bug 759996 may be relevant.

Boris, do you know what the latest on the spec is here?

(FWIW, I've not checked if/when this regressed)
Component: Untriaged → Layout
Flags: needinfo?(bzbarsky)
Keywords: reproducible, testcase
OS: Windows 7 → All
Product: Firefox → Core
Hardware: x86_64 → All
Summary: border-image does not work. Same example worked in 2010 and works in chrome today. → border-image with border-width but no border-style shows no border and has computed border-width of 0
It's a bug in Chrome.  See https://code.google.com/p/chromium/issues/detail?id=356802

The spec says (<http://dev.w3.org/csswg/css-backgrounds-3/#border-images>):

  The border-image properties do not affect layout: layout of the box, its content, and
  surrounding content is based on the ‘border-width’ and ‘border-style’ properties only.

so in the attached testcases the border width is 0 (due to the "border-style: none"; this part has been true all along without border-image involved) and hence the image is invisible.

> This used to work in firefox in 2010.

An early draft of the border-image spec had it overriding border-style and border-width values.  The spec changed to the current behavior in mid-2009, and we implemented those spec changes in Firefox 15, which shipped in August 2012, at which point we dropped the "-moz" prefix.  See bug 497995.

If a book written in 2010 was ignoring spec updates made in 2009, then that's really a problem with the book...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(bzbarsky)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.