Closed Bug 11201 Opened 21 years ago Closed 21 years ago

Entering a New Address Book card leads to a crash

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 11198

People

(Reporter: marina, Assigned: hangas)

Details

Steps to reproduce:
-open Address Book;
-click New Card, fill it out;
-click OK to enter it into the Personal Address Book;
//note : apprunner crashes
Incident ID: 11974479

 Trigger Type:  Program Crash

 Trigger Reason:  Access violation


 Call Stack:    (Signature = addrbook.dll + 0x47ad (0x600247ad) 77daef09)
   addrbook.dll + 0x47ad (0x600247ad)

   addrbook.dll + 0x5c4d (0x60025c4d)

   addrbook.dll + 0x3db7 (0x60023db7)

   xpcom.dll + 0x1b979 (0x60b1b979)

   xpc3250.dll + 0x7928 (0x607a7928)

   xpc3250.dll + 0x7f85 (0x607a7f85)

   js3250.dll + 0x134dd (0x608d34dd)

   js3250.dll + 0x172e3 (0x608d72e3)

   js3250.dll + 0x1351a (0x608d351a)

   js3250.dll + 0x172e3 (0x608d72e3)

   js3250.dll + 0x1351a (0x608d351a)

   js3250.dll + 0x172e3 (0x608d72e3)

   js3250.dll + 0x1351a (0x608d351a)

   js3250.dll + 0x1364b (0x608d364b)

   js3250.dll + 0x39dc (0x608c39dc)

   jsdom.dll + 0x16aa5 (0x60916aa5)

   raptorhtml.dll + 0x8ed6f (0x604ded6f)

   rdf.dll + 0x1eca8 (0x6057eca8)

   raptorhtml.dll + 0x8ff4c (0x604dff4c)

   raptorhtml.dll + 0x8f7df (0x604df7df)

   raptorhtml.dll + 0x25485 (0x60475485)

   raptorview.dll + 0x1d58 (0x60ac1d58)

   raptorview.dll + 0x63af (0x60ac63af)

   raptorview.dll + 0x242e (0x60ac242e)

   raptorwidget.dll + 0x506d (0x60ae506d)

   raptorwidget.dll + 0x50b3 (0x60ae50b3)

   raptorwidget.dll + 0x76df (0x60ae76df)

   raptorwidget.dll + 0x7992 (0x60ae7992)

   raptorwidget.dll + 0x6f82 (0x60ae6f82)

   raptorwidget.dll + 0x5163 (0x60ae5163)

   USER32.dll + 0x13ed (0x77e713ed)
Severity: normal → critical
Status: NEW → ASSIGNED
Target Milestone: M9
Which build does this happen on?  How many address books appear in the left pane?
How was Seamonkey launched?  Any other steps between launch and opening address
book?
This bug was observed with 1999-08-03-08 Win build.
There are no other steps in between opening AB (there are two AB on the left
pane),clicking New Card and clicking OK but one: i have 17'' monitor and the
card couldn't show up in full on the screen, you don't see "OK" and "Cancel"
buttons so you need to diminish Start toolbar on the bottom of the screen and
move the AB card to the most upper position to be able to click OK or Cancel. It
might influance the crash.
Is this still happening with today's build?  I'm able to enter every single
field into a new address book card without any problem.  One note, if I don't
have an address book selected I get the following js error when I hit OK:

cardproperty = [xpconnect wrapped nsIAbCard]
JavaScript error: uncaught exception: Component returned failure code: 0x8000400
5 [nsIAbCard.AddCardToDatabase, {file: file:///D|/raptor/mozilla/dist/WIN32_D.OB
J/bin/chrome/addressbook/content/default/abNewCardDialog.xul, line: 100}]
QA Contact: lchiang → esther
Candice checked in a bug fix that may have fixed some of these other crashes.

Candice, do you think you may have fixed this too?
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
After talking with Marina, she sent me an email stating this is probably a dup
of 11198.  I will Resolve as dup and check this scenario when 11198 is fixed.

*** This bug has been marked as a duplicate of 11198 ***
Status: RESOLVED → VERIFIED
Verified as Duplicate
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.