Absolute position span inside relative position span not painted correctly

RESOLVED DUPLICATE of bug 79315

Status

()

P3
major
RESOLVED DUPLICATE of bug 79315
17 years ago
15 years ago

People

(Reporter: ssotton, Assigned: attinasi)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20011128], URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
The eval() function in javascript does not work in Netscape 6.2.  It worked in 
earlier versions but seems to have stopped in 6.2.  eval does not generate a 
javascript error, it just does nothing.
works fine here... (linux build 2001-11-23-08).  How are you using it, exactly?

Comment 2

17 years ago
Stephen: without an example, testcase, or URL to go to, we'll have
to mark this one as invalid. Note the "Create a New Attachment"
link above if you have a (reduced) testcase. Otherwise, a URL to 
a testcase or website can be provided in the "URL" textbox above. 

Comment 3

17 years ago
Stephen has provided me with the URL above.

At this site, eval() is used to dynamically assign the CSS visiblity
of <SPAN> elements, as in:

  eval("document.getElementById(\"inner6\").style.visiblity=\"hidden\"")


and this is not working in Mozilla. Confirming with Mozilla trunk binary
200111265xx on WinNT. If you load the site in IE6, notice what happens
when you click the option buttons, like "Title" and "Author". Each time
you click one, look at "Enter search terms(s)". To the right of it,
you see dynamically assigned text, e.g. "example shakespeare,william".

That is, in IE6 you see it. In Mozilla you don't. No errors appear
in the JavaScript Console. The key functions using eval() are :


function ShowEx(iVis)
{
 for (i=1;i<=5;i++)
 {
  eval(layerRef + "inner" + i + styleRef + "visibility=\"hidden\"")
 }
 eval(layerRef + "inner" + iVis + styleRef + "visibility=\"visible\"")
}


function TabShow(iVis)
{
 for (i=1;i<=6;i++)
 {
  eval(layerRef2 + "tabinner" + i + styleRef + "visibility=\"hidden\"")
 }
 eval(layerRef2 + "tabinner" + iVis + styleRef + "visibility=\"visible\"")
}



And the eval strings here are like the one I gave above:

  eval("document.getElementById(\"inner6\").style.visiblity=\"hidden\"")
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Reassigning to DOM Style - 
Assignee: rogerl → jst
Component: Javascript Engine → DOM Style
QA Contact: pschwartau → ian
Summary: eval function of javascript does not work → Dynamic assignment of CSS visibility not working?
Phil, thanks for the data!

DOM style is working correctly.  Layout is not.  The problem is an absolutely
positioned span (block) inside a relatively positioned span (inline).

Attaching a minimal non-dynamic testcase.
Component: DOM Style → Layout
reassign for real
Assignee: jst → attinasi
QA Contact: ian → petersen
Created attachment 59560 [details]
You should see text ("This is a sentence.")
Created attachment 59561 [details]
giving the outer span a border makes things work for some reason...
Summary: Dynamic assignment of CSS visibility not working? → Absolute position span inside relative position span not painted correctly
Created attachment 59573 [details]
Simplified testcase

Comment 10

17 years ago
setting to 9.9
Priority: -- → P3
Whiteboard: [bae:20011128]
Target Milestone: --- → mozilla0.9.9
(Reporter)

Comment 11

17 years ago
I can confirm that giving the outer layers a border:

#outer {position: relative; vertical-align: top; border-color: #FAF0E6;
border-style: solid;}

#tabouter {position: relative; vertical-align: top; border-color: #FFCE63;
border-style: solid;}

makes the page work.  The border-style cannot be "none".

Updated

17 years ago
Target Milestone: mozilla0.9.9 → Future
(Reporter)

Comment 12

17 years ago
Congrats.  Version 0.9.9 seems to have fixed it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Sorry, reopening.  The testcases in this bug still fail for me with a current
tip build on Linux....
Status: RESOLVED → REOPENED
OS: Windows 2000 → All
Hardware: PC → All
Resolution: FIXED → ---
(Reporter)

Comment 14

17 years ago
After additional testing, I'm in agreement with Boris -- the problem is NOT fixed.
(Reporter)

Comment 15

17 years ago
If I change the outer, container (#outer and #tabouter in the example) from a
<span> to a <div>, this also makes it work with Mozilla, so the problem must
have something to do with handling of <span>'s.  I'd rather not have to do this
since it screws up the spacing.
Summary: Absolute position span inside relative position span not painted correctly → {ib}Absolute position span inside relative position span not painted correctly
(Reporter)

Comment 16

17 years ago
The problem is still present in 1.0 RC1.
(Reporter)

Comment 17

17 years ago
It's disappointing, the final release of 1.0 is out and it still has the bug.
Maybe a duplicate of bug 79315.
Summary: {ib}Absolute position span inside relative position span not painted correctly → Absolute position span inside relative position span not painted correctly

Comment 19

15 years ago
Dup, and this was fixed. Yay!

*** This bug has been marked as a duplicate of 79315 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.