If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot comment on Youtube.com

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: andrei, Unassigned)

Tracking

36 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20150123])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141202004003

Steps to reproduce:

1) brand new profile
2) install all my addons (long list, check the video)
3) comment on youtube and it works
4) use firefox for some time and youtube comments don't work anymore
5) restart firefox with adons disabled in safe mode and youtube comments still don't work
http://youtu.be/mFHO8YYjsAg
Please help me troubleshoot this. 



Actual results:

I don't see a avatar in the comments section of youtube and when I click the comment box a new tab opens and closes fast check the video http://youtu.be/mFHO8YYjsAg In the video I have all my enabled but I also restarted it with addons disabled and in safe mode. The real issue here is the fact that the problem persists after I remove the addons. I suspect it is something in my about:config that is changed by a addon. This happens for a few months now and it is not related to a specific FF version, all are affected.


Expected results:

I should be able to comment on youtube.

Comment 1

3 years ago
Reporter, would you be able to do a clean install of Firefox and your addons, excluding the following addons:

1. 1-Click YouTube Video Downloader 2.3.7
2. Disconnect 3.14.0
3. Adblock Edge 2.1.7
4. Privacy Badger Firefox 0.1.4
5. Privly 0.3.3
6. Lightbeam 1.1.1
7. YouTube High Definition 34.3

I've suggested the above as 1 and 7 may change the way YouTube behaves, and the rest as they may clash with one another considering they mostly do the same and/or similar features.

Please report back on the results of testing without these addons on a clean installation. If it then works, try each addon one by one until you find the culprit. If it still does not work on a clean installation, please report as much.
Flags: needinfo?(andrei)
(Reporter)

Comment 2

3 years ago
Thank you for your input. I will try this (I hope this weekend)
Flags: needinfo?(andrei)
(Reporter)

Comment 3

3 years ago
Can the "clean install" be a new profile and not an actual "clean" install?
(Reporter)

Comment 4

3 years ago
I installed a fresh Firefox 33 on a Fedora 21 in a VirtualBox and I created a new profile for my Arch GNU/Linux Firefox Developer Edition 37 with all the addons except the ones mentioned by you. I can post comments on both. I will try each addon in your list to see which one creates the issue. Is there any way I can export all the non-defaults in about:config? The thing is that I disable all the adons and I run in safe mode the problem still persists. I suspect one of the addons changes something in "about:config" that makes the bug reproduce on ff with addons disabled. I'm so glad there is the "Browser Toolbox" so I can seriously debug this :D

Comment 5

3 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

I cannot reproduce, comments in YouTube work fine for me.
Whiteboard: [testday-20150123]

Comment 6

3 years ago
(In reply to andrei from comment #4)
> I installed a fresh Firefox 33 on a Fedora 21 in a VirtualBox and I created
> a new profile for my Arch GNU/Linux Firefox Developer Edition 37 with all
> the addons except the ones mentioned by you. I can post comments on both. I
> will try each addon in your list to see which one creates the issue. Is
> there any way I can export all the non-defaults in about:config?

The prefs.js file in your profile generally only lists prefs that have changed compared to the default.

Note that there might be other changes like permissions changes which aren't stored in the prefs, which add-ons might be making...

Let us know if you figure out what causes this...
Flags: needinfo?(andrei)
(Reporter)

Comment 7

3 years ago
I did not have time to investigate this more. It bothers me pretty much so I will come up with more info soon.
Flags: needinfo?(andrei)
(Reporter)

Comment 8

3 years ago
Sorry for the late reply. I disabled 1-Click YouTube Video Downloader and YouTube High Definition, created a fresh new profile and synced with my FF sync account. I only sync extensions and bookmarks, no preferences. It seems to work now. I will try this profile for several days if it works I will add a bug report to one of the two extensions.

Comment 9

3 years ago
Bug NOT reproduced.
* Tested on Version- Firefox 36.04 Mozilla Firefox for Ubuntu canonical -1.0.
* System- Ubuntu 12.04 LTS.
* Addons unable to install
        1. jump tab counter
        2 DarWDec
        3 GNotifier
        4 ProfileSwitcher
Result- Was able to comment on Youtube videos after installing the Addons, as I as able to before installation

Comment 10

2 years ago
Did you found the relevant Add-On? If so, you may close this bug and link to the new report.
Flags: needinfo?(andrei)
(Reporter)

Comment 11

2 years ago
Sorry for the late reply. It does not reproduce anymore on the latest stable Firefox with updated addons. Don't know why :(

I removed

1-Click YouTube Video Downloader
Disconnect
Adblock Edge (replaced with uBlockOrigin)
Privly
Lightbeam
YouTube High Definition

I fixed my issue, I will close it since I do not think pinpointing the addon gives back much value. A lot of people are porting their adons to the new API, so even if I find the broken addon, it might change in the near future.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(andrei)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.