Closed Bug 1120267 Opened 7 years ago Closed 7 years ago

[First Time Experience] Can't join a hidden network via FTU.

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M verified, b2g-v2.1 verified, b2g-v2.1S verified, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S4 (23jan)
blocking-b2g 2.0M+
Tracking Status
b2g-v2.0 --- wontfix
b2g-v2.0M --- verified
b2g-v2.1 --- verified
b2g-v2.1S --- verified
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: seinlin, Assigned: lchang)

References

Details

Attachments

(4 files)

Can't join a hidden network via FTU.
Duplicate of this bug: 1107015
blocking-b2g: --- → 2.0M?
Blocks: Woodduck
blocking-b2g: 2.0M? → 2.0M+
Attached file Pull request to master
Hi Fernando,

Could you please help reviewing this simple patch? Thanks.
Assignee: nobody → lchang
Status: NEW → ASSIGNED
Attachment #8547280 - Flags: review?(fernando.campo)
Depends on: 1080799
Comment on attachment 8547280 [details] [review]
Pull request to master

code looks good and patch is simple enough, but right now I can't test it as I don't have access to any router to create a hidden ssid wifi. I'll test it tomorrow.
Comment on attachment 8547280 [details] [review]
Pull request to master

finally tested on hidden wifi, works good :)

thanks for taking care of it!
Attachment #8547280 - Flags: review?(fernando.campo) → review+
Hi Fernando, Thanks for your review.


Gaia-try is passed: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=afa4da752d5d

I'll land it once the tree is open.
landed on master: https://github.com/mozilla-b2g/gaia/commit/e34bf0d0ea0538be50f117bd9a53d4e62ee90f4d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 8547280 [details] [review]
Pull request to master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): broken function
[User impact] if declined: users can't join any hidden WIFI in FTU
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): N/A
[String changes made]: N/A
Attachment #8547280 - Flags: approval-gaia-v2.2?
Attachment #8547280 - Flags: approval-gaia-v2.1?
Comment on attachment 8547280 [details] [review]
Pull request to master

Approving the low risk patch here. It'll be great if QA can help with verfication of this once it lands on branches.
Attachment #8547280 - Flags: approval-gaia-v2.2?
Attachment #8547280 - Flags: approval-gaia-v2.2+
Attachment #8547280 - Flags: approval-gaia-v2.1?
Attachment #8547280 - Flags: approval-gaia-v2.1+
Keywords: verifyme
This issue is verify successfully on Flame 2.1,2.2 and woodduck 2.0M.
Reproducing rate: 0/5
See attachment: Verify_Flame_WIFI.mp4

Flame 2.1 build:

Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150118001331
Version         34.0

Flame 2.2 build:

Gaia-Rev        f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8067c111ddff
Build-ID        20150118002501
Version         37.0a2

Woodduck 2.0 build:

Gaia-Rev        12deb9378928835addbf06bdf907429d58512296
Gecko-Rev       20943fe7b54c63a375952fbd8dd396a22ee893e7
Build-ID        20150119050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1421615136
FW-Date         Mon Jan 19 05:06:02 CST 2015
Attached video Verify_Flame_WIFI.MP4
This issue has verify successfully on Flame 3.0.
See attachment: verified_Flame3.0.mp4.
Reproduce rate: 0/5.

Flame3.0 build version:

Gaia-Rev        0f662dffef27599443cfcd790c2b39190a2b35c8
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/fa91879c8428
Build-ID        20150125160206
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.193329
FW-Date         Sun Jan 25 19:33:40 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: MGSEI-Triage+
Attached video Verify_Flame3.0.MP4
Attached video 2.1s video
This problem is verified pass on latest build of 2.1S 256mb/512mb.
STR:
1. Build in latest ROM and enter FTU(Or launch FTU via Settings app).
2. Enter “Select a network” view and tap “Join hidden network”.
3. Input SSID name and password.
4. Tap “Join”.
** The hidden network can be joined successfully.
See attachments: Verify_2.1s_video.MP4
Rate: 0/5

2.1S_512m build:
Build ID               20150301161204
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ea
Firmware(Release)      4.4.2
Firmware(Incremental)  122
Firmware Date          Thu Feb  5 12:42:58 CST 2015

2.1S_256m build:
Build ID               20150301161204
Gaia Revision          a43d64ae01ef108aa4dcc971c770fecd8416a764
Gaia Date              2015-02-26 09:24:39
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1s/rev/2437280c634f
Gecko Version          34.0
Device Name            scx15_sp7715ga
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150301.194157
Firmware Date          Sun Mar  1 19:42:09 EST 2015
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.