Feature Proposal: Improve display of inbound/received VCARD files

RESOLVED DUPLICATE of bug 1119190

Status

--
enhancement
RESOLVED DUPLICATE of bug 1119190
4 years ago
4 years ago

People

(Reporter: Synper311, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8547359 [details]
Current display of inbound/received VCard file

Currently, inbound VCard files are issued the bone-stock "generic" media placeholder image, and do not have any text to help describe them.

In Bug 1111377, I proposed that the "View message report" panel would show information about every attached file in an MMS, including size, file name, and MIME-Type.

Along those lines, I think that received VCards should be given an identifiable icon unique to VCards under FFXOS, and the file name should be displayed under the icon for the VCard in the MMS message.

These will help the user to understand the attachment, and whether or not they wish to "click through".

I don't know what this file is, nor do I have a remote means to guess. With a unique type icon and the file name visible, I have a higher likelihood of understanding both.
(Reporter)

Comment 1

4 years ago
Created attachment 8547375 [details]
2015-01-12-01-14-01_edit.jpg

Here's an admittedly very ugly and simple preliminary mock-up of what this could look like.

Key points: 
1) VCard has a sensible, unique, and FFXOS appropriate icon that helps convey what this object is to the user.

2) File Name is drawn under the VCard icon with a "friendly" name for the .vcf extension, telling the user that this is CONTACTNAME (VCard).
Actually, some work for this is under implementation. see bug 1119190 :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119190
You need to log in before you can comment on or make changes to this bug.