[Flame][Music]Tap the song on transfer notification by BT to play, the play view displays at the uper half of screen.

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: zikui.yang, Assigned: evanxd)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame][v2.2][Music]Receive a song by BT. When I search by rocket bar, tap the alert message of file transfer on top of screen,it will play the song,you can see the play view shown as a half.
Attchment:logcat_0340.txt and  VIDEO0032_Compress.MP4
Happen time:3:40


[2.Testing Steps]: 
Precondition:Enable BT and pair device A with another phone B by BT.
1.Try to send a song from phone B by BT,then transfer request will be receiced by device A
2.Tap Transfer to begain transfering song
3.launch music on device A
4.drag down to envoke Search bar,tap Search music box
5.Tap the top left of screen to invoke rokect bar
6.Input some words
>>the search result will be shown
7.Waiting for the song transfer completion.
8.Tap the notification on the top of screen to play the song


[3.Expected Result]: 
8.The Music play view should be shown as full screen.

[4.Actual Result]: 
8.The Music play view displays as a half screen.

[5.Reproduction build]: 
Flame 2.2 build:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150111.043244
FW-Date         Sun Jan 11 04:32:55 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Posted file logcat_0340.txt
(Reporter)

Comment 2

4 years ago
This looks like a window management issue?
Component: Gaia::Music → Gaia::System::Window Mgmt
Hi Eli, Could you check this also on V2.1, thanks.
QA Whiteboard: [COM=Gaia::System]
Flags: needinfo?(zikui.yang)
(Reporter)

Comment 5

4 years ago
This issue  does NOT exist on Flame 2.1

(In reply to Eric Chang [:ericcc] [:echang] from comment #4)
> Hi Eli, Could you check this also on V2.1, thanks.

This issue does not exist on Flame 2.1
Gaia-Rev        77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/452a023ae7b2
Build-ID        20150118001331
Version         34.0
Device-Name     flame
FW-Release      4.4.2
Flags: needinfo?(zikui.yang) → needinfo?(echang)
Set 2.2? for regression.
blocking-b2g: --- → 2.2?
Flags: needinfo?(echang)
Keywords: regression

Comment 7

4 years ago
Triage: regression blocking
Assignee: nobody → alive
blocking-b2g: 2.2? → 2.2+
Either of you could take this? Thanks.
Flags: needinfo?(gduan)
Flags: needinfo?(evanxd)
(Assignee)

Comment 9

4 years ago
Sure.
Assignee: alive → evanxd
Flags: needinfo?(evanxd)
(Assignee)

Updated

4 years ago
Flags: needinfo?(gduan)
(Assignee)

Comment 10

4 years ago
Posted file WIP Patch (obsolete) —
The patch already fixed the problem. But I need to investigate more to make sure I was doing on the right way.
(Assignee)

Comment 11

4 years ago
Found out the root cause, and wrote a patch for it.
Waiting for CI result and thinking how to write tests for this issue.
Attachment #8552276 - Attachment is obsolete: true
(Assignee)

Comment 12

4 years ago
Comment on attachment 8552950 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27553

Hi Alive,

Could you help to review the patch?
If it is on the right way, I'll add unit tests for it.

Thanks.
Attachment #8552950 - Flags: review?(alive)
Comment on attachment 8552950 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27553

LGTM
Attachment #8552950 - Flags: review?(alive) → review+
(Assignee)

Comment 14

4 years ago
Thanks for the review, alive.

Added unit tests. Wait for CI result and tree to land.
(Assignee)

Comment 15

4 years ago
Tree is opened.
Push again, and waiting for the CI result.
(Assignee)

Comment 16

4 years ago
Gb job in CI is failed.
Waif for the fixing by Bug 1127210.
(Assignee)

Comment 18

4 years ago
Comment on attachment 8552950 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/27553

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): none.
[User impact] if declined: Could not play music in a full(just half) screen activity window when he/she activates search window on the rocket bar.
[Testing completed]: It works on local device, and the CI works well.
[Risk to taking this patch] (and alternatives if risky): Small risk, we just changed one if-else logic.
[String changes made]: none.
Attachment #8552950 - Flags: approval-gaia-v2.2?(bbajaj)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S5 (6feb)
Keywords: verifyme
Attachment #8552950 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+

Comment 20

4 years ago
This issue has been verified successfully on Flame2.2&3.0

STR:
Precondition:Enable BT and pair device A with another phone B by BT.
1.Try to send a song from phone B by BT,then transfer request will be receiced by device A
2.Tap Transfer to begain transfering song
3.launch music on device A
4.drag down to envoke Search bar,tap Search music box
5.Tap the top left of screen to invoke rokect bar
6.Input some words
>>the search result will be shown

7.Waiting for the song transfer completion.
8.Tap the notification on the top of screen to play the song

Occur rate: 0/10


Flame 2.2 build:
Build ID               20150203002504
Gaia Revision          cd62ff9fe199fb43920ba27bd5fdbc5c311016fc
Gaia Date              2015-02-03 00:56:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/11d93135c678
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.041704
Firmware Date          Tue Feb  3 04:17:15 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150203055658
Gaia Revision          ae5a1580da948c3b9f93528146b007fc4f6a712b
Gaia Date              2015-02-02 19:50:21
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ae5d04409cd9
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150203.093120
Firmware Date          Tue Feb  3 09:31:32 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED

Updated

4 years ago
QA Whiteboard: [COM=Gaia::System] → [COM=Gaia::System][MGSEI-Triage+]
Per Comment 20, clear the verifyme tag and switch status to RESOLVED-FIXED.
Status: VERIFIED → RESOLVED
Last Resolved: 4 years ago4 years ago
Keywords: verifyme
(In reply to Shine from comment #21)
> Per Comment 20, clear the verifyme tag and switch status to RESOLVED-FIXED.

Sorry for this comment, switch status to VERIFIED-FIXED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.