[Flame][Settings]Device can't enter any item in Settings page.

VERIFIED FIXED in Firefox OS v2.1

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jihao, Assigned: eragonj)

Tracking

({regression})

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.1+, b2g-v2.1 verified, b2g-v2.2 unaffected, b2g-master unaffected)

Details

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
Created attachment 8547459 [details]
logcat_flame_0139.txt

[1.Description]:
[Flame][v2.1][Settings]Device can't open any item in Settings page when we reopen Settings after entering  "No internet connection" item to connect a WIFI.

Attachement: logcat_flame_0139.txt and can't_enter.3gp
Occurrence time: 01:39

[2.Testing Steps]: 
Set up:No any one data connected.
1. Open Setting.
2. Tap the E.me in Settings page.
3. Input any character.
4. "No internet connection" prompt pops up and tap it.
5. Network & Connectivity setting page pops up and tap WIFI item.
6. Connection a Wifi.
7. Tap < button.
8. Tap Done button.
9. Tap Home button and Reopen Settings.


[3.Expected Result]: 
8. Device shoule come back to  previous page.
9. Device shoule be opening every one item.

[4.Actual Result]: 
8. Device is still stay on  Network & Connectivity setting page.
9. Device can't open any one item in Settings page.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        64db236bea9a0510567ab7ced2f2b4688737123c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/273f24a1d1fe
Build-ID        20150111001202
Version         34.0

Flame 2.2 build:
Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223
Version         37.0a1

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8547466 [details]
can't_enter.3gp

Comment 2

4 years ago
[Blocking Requested - why for this release]:

Very bad user experience and basic functionality is broken.
blocking-b2g: --- → 2.1?

Updated

4 years ago
blocking-b2g: 2.1? → 2.1+
Keywords: regression, regressionwindow-wanted
QA Contact: jmercado
I did some verification of the branch checks and this issue DOES occur on both 2.2 and 2.1 Flame but is not 100%  repro.  I had to reset my phone between attempts and was able to reproduce on both branches.  Finding the regression window now.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150112074532
Gaia: b0254d13e67b0bd4c74c2f2c9b9ea1251949d9fe
Gecko: cac64af410a1
Version: 37.0a1 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Environmental Variables:
Device: Flame 2.1
BuildID: 20150112105749
Gaia: 836e6d74cb8b7016df555f85445893b3ff9aac12
Gecko: 710922989c44
Version: 34.0 (2.1) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Cannot reproduce because the rocketbar is not accessible in settings in 2.0 builds.
Environmental Variables:
Device: Flame 2.0
BuildID: 20150112105648
Gaia: 31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko: 8bdac875f08a
Version: 32.0 (2.0) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
status-b2g-v2.2: unaffected → affected
Flags: needinfo?(ktucker)

Updated

4 years ago
Assignee: nobody → ejchen
The changes introduced for Bug 1039189 seems to have caused this issue.  Before this point it was not possible to open the connectivity settings through the search bar.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140818140315
Gaia: b33b4d9558e0b9eabbfda7be23435e2b38fd40bf
Gecko: 8d52881891a5
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

First Broken 
Environmental Variables:
Device: Flame 2.1
BuildID: 20140818141716
Gaia: 2ca015edb16705e9021bd9508ee7e2659fe0c4bb
Gecko: 203c872ae6d1
Version: 34.0a1 (2.1) 
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Last Working gaia / First Broken gecko - Issue does NOT occur
Gaia: b33b4d9558e0b9eabbfda7be23435e2b38fd40bf
Gecko: 203c872ae6d1

First Broken gaia / Last Working gecko - Issue DOES occur
Gaia: 2ca015edb16705e9021bd9508ee7e2659fe0c4bb
Gecko: 8d52881891a5

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/b33b4d9558e0b9eabbfda7be23435e2b38fd40bf...2ca015edb16705e9021bd9508ee7e2659fe0c4bb
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regressionwindow-wanted
Francisco, can you take a look at this issue please? Looks like the implementation for bug 1039189 may have caused this issue to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(francisco)
@Paladin (or @Jayme),

can you help to use "adb pull /system/b2g/webapps/settings.gaiamobile.org/application.zip application.zip" to pull out the zip file and upload it here ? Because I just noticed there is one JS error in our main file from the log, I want to check what's going on.

And I don't think reverse Bug 1039189 would help here because that is another user story that we want to implement to make user happy if they are using phone offline. From my point, I think we should find out the root cause about what makes this bug happen.
Flags: needinfo?(jihao)
(Reporter)

Comment 7

4 years ago
Created attachment 8548657 [details]
application.zip

I have uploaded file.
Flags: needinfo?(jihao) → needinfo?(ejchen)
hard to reproduce ..

Is there any easy ways that we can reproduce this easily on master / 2.1 (?!)

And is there any additional change in System app (Settings app) when finding this bug ?

Any tip would be thankful :)
Flags: needinfo?(ejchen) → needinfo?(jihao)
(Reporter)

Comment 9

4 years ago
Hi jayme,
I don't think there is other way to reproduce this issue on Flame 2.1
Could you help handle the question on Comment #8?

--------------------------------------------------------------------------
This issue can be repro on latest Flame 2.1
Reproducing rate: 5/5
Device Info:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150114001300
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.035135
FW-Date         Wed Jan 14 03:51:46 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(jihao) → needinfo?(jmercado)

Comment 10

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #8)
> hard to reproduce ..
> 
> Is there any easy ways that we can reproduce this easily on master / 2.1 (?!)
> 
> And is there any additional change in System app (Settings app) when finding
> this bug ?
> 
> Any tip would be thankful :)

Hi, EJ,

I also can easy reproduce this bug.

Please follow each step that noted on comment 0.
The key step is to launch the settings app firstly.

You also can follow the demo video to reproduce this bug.
- https://bugzilla.mozilla.org/attachment.cgi?id=8547466

If you need further assistance, please feel free to find me.
Many thanks.
Flags: needinfo?(jmercado)
Flags: needinfo?(francisco)
Flags: needinfo?

Updated

4 years ago
Flags: needinfo?
Status: NEW → ASSIGNED
Hi @Jenny,

Currently, based on comment 0, if you are staying at Settings app and want to open settings app from search bar, you will notice that when you press "Done", the app would be stopped and no matter how you do, current instance would be broken and is not able to work properly.

Per offline discussion with Arthur, in 2.1, we didn't land "Inline Activity" patch and that's why we won't create another new instance of Settings app but use the old one. Right now in Settings, we don't have any mechanism that would keep the state of every panel to make you easily jump between panels. And yes, this is why we need "Inline Activity" after 2.1. (You can do something like toggle Wifi / Airplane mode in a new instance and we won't mess up with the old one)

So back to this bug, we think the better way to fix this bug is close the Settings app after pressing "Done" button. For normal cases (App X -> Settings app -> press Done -> back to App X), nothing got changed, everything still works well. While for this edge Case (Settings app -> jump to Settings app from search bar -> press Done -> back to homescreen), we would close Settings app when everything is done and users will be redirected back to homescreen.

For us, this would be the best fix coming from our minds but this needs confirmation with you before moving on, so can you give us some ideas ?

Big thanks !!
Flags: needinfo?(jelee)

Comment 12

4 years ago
Hi EJ,

I think what you guys suggested makes a lot of sense, feel free to go forward with the solution. Thanks =)!
Flags: needinfo?(jelee)
William, I realized that this bug can be reproduced on v2.1, but I haven't successfully reproduced once on latest v2.2 build.

Can you help to reproduce once and lend the phone to me ? THanks !! :)
Flags: needinfo?(whsu)

Comment 15

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #14)
> William, I realized that this bug can be reproduced on v2.1, but I haven't
> successfully reproduced once on latest v2.2 build.
> 
> Can you help to reproduce once and lend the phone to me ? Thanks !! :)

Hi, EJ,

Perhaps, Build info ( #comment 0 ) can help you reproduce this bug on v2.2.
Any purpose makes you to reproduce it on latest build?
:)
Flags: needinfo?(whsu)
Yes, that's the problem.

I did try to use QA's flash tool to flash that build id but with no luck and got some error messages from console like this : 

--
### INFO: The path of build id is: /2015/01/2015-01-11-01-02-23/
### INFO: Get available packages list from https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g37_v2_2-flame-kk-eng/2015/01/2015-01-11-01-02-23/
### INFO: HTTP Error: 404 Not Found
### INFO: The path of build id is: /2015/01/2015-01-11-01-02-23/
### INFO: Set up dest folder to [pvt/mozilla-b2g37_v2_2-flame-kk-eng/2015/01/2015-01-11-01-02-23/].
### INFO: Invalid build ID: 20150111010223, reset to latest
### INFO: Get available packages list from https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g37_v2_2-flame-kk-eng/latest/
### INFO: Set up dest folder to [pvt/mozilla-b2g37_v2_2-flame-kk-eng/latest].
--

No matter how, I did try several times on v2.2 but I can't reproduce it and that's why I need your help ! (Maybe you got another phone that can reproduce this XD ?)

Thanks !
Flags: needinfo?(whsu)

Comment 17

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #16)
> Yes, that's the problem.
> 
> I did try to use QA's flash tool to flash that build id but with no luck and
> got some error messages from console like this : 
> 
> --
> ### INFO: The path of build id is: /2015/01/2015-01-11-01-02-23/
> ### INFO: Get available packages list from
> https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-
> b2g37_v2_2-flame-kk-eng/2015/01/2015-01-11-01-02-23/
> ### INFO: HTTP Error: 404 Not Found
> ### INFO: The path of build id is: /2015/01/2015-01-11-01-02-23/
> ### INFO: Set up dest folder to
> [pvt/mozilla-b2g37_v2_2-flame-kk-eng/2015/01/2015-01-11-01-02-23/].
> ### INFO: Invalid build ID: 20150111010223, reset to latest
> ### INFO: Get available packages list from
> https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-
> b2g37_v2_2-flame-kk-eng/latest/
> ### INFO: Set up dest folder to [pvt/mozilla-b2g37_v2_2-flame-kk-eng/latest].
> --

Oh! You select the wrong branch because the build was a master build at that time.
You need to select "Mozilla-central", and input the build ID on the "Build ID" field.

Gaia-Rev        f5e481d4caf9ffa561720a6fc9cf521a28bd8439
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/bb8d6034f5f2
Build-ID        20150111010223

> No matter how, I did try several times on v2.2 but I can't reproduce it and
> that's why I need your help ! (Maybe you got another phone that can
> reproduce this XD ?)

I also cannot reproduce this bug on latest v2.2 now.
We can NI Paladin to see if Paladin can reproduce it again on v2.2
, and then I can try to narrow down the reproduction steps.

--- -- - --- -- - --- -- - --- -- - --- -- - --- -- -
Hi, Paladin,

Could you try to reproduce this bug on latest v2.2 build to see if it still happens?
Many thanks.
Flags: needinfo?(whsu) → needinfo?(jihao)
Thanks William !!!  ;)
(Reporter)

Comment 19

4 years ago
Hi William,
I also can't reproduce this issue on latest Flame 2.2.
Reproducing rate: 0/10

Device info:
Flame 2.2 build:
Gaia-Rev        cd42b034fd2825c3675ace3a67f5775eb61c2d60
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d824c65a6a2b
Build-ID        20150128002506
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150128.035910
FW-Date         Wed Jan 28 03:59:20 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(jihao)
(Reporter)

Updated

4 years ago
Flags: needinfo?(whsu)
Ok let's keep this bug focusing on fixing 2.1 ?

Comment 21

4 years ago
Hi, EJ,

Sorry to disturb you again and again!

Some patches might impact the test result of 2.2 branch.
I suggest that we can uplift this patch to v2.1, but monitor the v2.2 branch to see if it still happens.
If you agree, I will clone this bug ( for v2.2 branch) and mark the new bug as "WORKFORME".

What do you think? :)
Flags: needinfo?(whsu) → needinfo?(ejchen)
Sure ! Let's do this !

I'll start to ask for approval for 2.1 patch, thanks all !!!
Flags: needinfo?(ejchen)
Comment on attachment 8555054 [details]
patch on 2.1

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): no
[User impact] if declined: if users try to access settings app inside settings app, this bug will happen and would make the whole settings app unable to use.
[Testing completed]: no, this bug doesn't exist in master, so this patch is mainly a workaround after discussing with UX.
[Risk to taking this patch] (and alternatives if risky): low
[String changes made]: no
Attachment #8555054 - Flags: approval-gaia-v2.1?

Comment 24

4 years ago
(In reply to EJ Chen [:eragonj][:小龍哥][ni? if you need me] from comment #22)
> Sure ! Let's do this !
> 
> I'll start to ask for approval for 2.1 patch, thanks all !!!

Cool! Thanks EJ! :)

Updated

4 years ago
Attachment #8555054 - Flags: approval-gaia-v2.1? → approval-gaia-v2.1+
Based on comment 17, comment 19, this bug should be focused on v2.1 only, so let me update the tracking flags here.

And also, mark checkin-needed to make sure this bug would be uplifted. Thanks all.
status-b2g-v2.2: affected → unaffected
Keywords: checkin-needed
v2.1: https://github.com/mozilla-b2g/gaia/commit/5d5163069da2c660261399002e88b4cbb9135f1e
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.1: affected → fixed
status-b2g-master: --- → unaffected
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S5 (6feb)

Updated

4 years ago
Keywords: verifyme
Created attachment 8561206 [details]
Verify_video.mp4

The problem is verified not happen on latest Flame 2.1 build.

Steps:
Set up:No any one data connected.
1. Open Setting.
2. Tap the E.me in Settings page.
3. Input any character.
4. "No internet connection" prompt pops up and tap it.
5. Network & Connectivity setting page pops up and tap WIFI item.
6. Connection a Wifi.
7. Tap < button.
8. Tap Done button.
9. Reopen Settings.

Actual Result:
8. Device back to Homescreen.
9. Device can opening every one item.

Fail rate:0/10
See attachment:Verify_video.MP4

Flame 2.1 version:
Build ID               20150208001349
Gaia Revision          4a14bb118d55f3d15293c2ff55b7f29f9b0bfcdb
Gaia Date              2015-02-06 20:37:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6cbe28d0bb8c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150208.035350
Firmware Date          Sun Feb  8 03:54:01 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
status-b2g-v2.1: fixed → verified
Keywords: verifyme

Comment 28

4 years ago
Hi Ryan,

Could you help land this patch on v2.1s? 

Thanks.
Flags: needinfo?(ryanvm)
Vincent is handling the 2.1s branch.
Flags: needinfo?(ryanvm)
You need to log in before you can comment on or make changes to this bug.