If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

email system can't handle @ symbol in local name part of email address

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
3 years ago
9 months ago

People

(Reporter: snork, Unassigned)

Tracking

SeaMonkey 2.30 Branch
seamonkey2.50
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2016-12-25 WORKSFORME])

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30
Build ID: 20141013232656

Steps to reproduce:

Using Seamonkey 2.30, Kbuntu 14.04LTS

Receive an email with "Name@Yahoo <xyz@yahoo.com>" in the header (no quotes), as the recipient.  The sender obviously has that person listed with the @ symbol in the local part of the mail address.


Actual results:

When I simply hit reply (or reply all), the email bounces. The bounced email shows that it tried to deliver the email to:

Name@yahooxyz@yahoo.com

Instead of to xyz@yahoo.com

which fails.


Expected results:

It looks like Seamonkey email client assumes that anything after the first occurrence of an @ symbol is the domain name. It can't parse what it sees in the header's email address properly. It should be looking within the <> brackets for the proper recipient's email address and ignoring the first part.
(Reporter)

Comment 1

3 years ago
Meant to say that the sender did NOT have that person listed with the @ symbol in the local part of the email address. i.e. the part of the email address before the @ symbol.

Comment 2

3 years ago
How about:
"Name@Yahoo" <xyz@yahoo.com>
(Reporter)

Comment 3

3 years ago
I have no control over how the sender has this configured at their end. Remember, I receive the email with that in the header. It looks like this, when I show headers: Name@Yahoo <xyz@yahoo.com>

When I click 'reply', it gets sent as: Name@yahooxyz@yahoo.com

I don't want to have to check the header of all my emails to see if there is a recipient with the @ symbol in their name, then delete that recipient and add it correctly every time.

None of the people that I've ask, using Windoze has this problem so their email client seems to handle this OK. I understand that the @ symbol is not allowed in the 'local' part of the email address according to the specs, and I have asked the senders (yes plural) to change that, so I'm not sure if this really is a bug or not. It's just annoying. I just think it would be nice to have Seamonkey parse that, proper or not.

Comment 4

3 years ago
I think I just got hit by this one and supply my testcase here.

I received an email with this from address:
"Brad @ DigiCert Support" <support@digicert.com>

When I hit reply, the composer correctly shows this in the to field:
Brad @ DigiCert Support <support@digicert.com>

But when I send it, SeaMonkey actually tries to send to this address:
<"Brad@DigiCert Supportsupport"@digicert.com>

Comment 5

10 months ago
Should be fixed by jcranmer's rewrite of the mime paser code.
Whiteboard: [CLOSEME 2016-12-25 WORKSFORME]

Comment 6

9 months ago
@reporter / @kjell@rilbe.se:
Can you confirm Comment 5: fixed?
Flags: needinfo?(kjell)

Comment 7

9 months ago
In SeaMonkey, I tried to write a message to:
"kjkadjakdj d@fkjf" <kjell@mise.se>

It was received as:
"kjkadjakdj d"@fkjf <kjell@mise.se>

Note the misplaced second double quote.

Replying to this message results in a message to:
"kjkadjakdj d"@fkjf <kjell@mise.se>

This address seems to work and deliver the message to kjell@mise.se.

So, I'd say it's fixed in terms of getting the messages delivered to the right address, but there still seems to be something wrong with the quotes.
Flags: needinfo?(kjell)

Comment 8

9 months ago
I don't get these messages with latest Trunk 2.50 any longer

Updated

9 months ago
See Also: → bug 1329698

Comment 9

9 months ago
Because we seem to have a partial fix for the reported problem I close this one as WFM / SM 2.50.

For the problem described in Comment 7 I submitted new "Bug 1329698 - email system can't handle @ symbol in local name part of email address"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
Target Milestone: --- → seamonkey2.50
You need to log in before you can comment on or make changes to this bug.