window.history.back does not function correctly

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: raz, Assigned: radha)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
on devedge.netscape.com, in the javascript documentation, it is stated that
framesets are window objects, and contain their own history for the locations
they have been at.  When you call a frameName.history.back() or just plain
history.back() scoped inside a window, it operates on _top.  I am developing a
web UI which has two frames... a tree, and content.. a basic layout design. 
When somone hits a button in the content frame which does a history.back(), the
_top level window, which contained the frameset for the tree and content frame
is operated on, taking me to the point before the frameset was ever created...
no matter how many links i have followed inside the content frame.
session history
Assignee: blakeross → radha
Component: History: Global → History: Session
(Reporter)

Comment 2

17 years ago
The problem was caused by a strange issue in the web code (under a different 
mozilla bug now) which caused the 'constant loading' syndrome.  It's worth 
noting that that is still a bug, but it is in not the bug reported here.  
Closing (bug being tracked elsewhere)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
mass-verifying Invalid bugs which haven't changed since 2001-12-31.

use the search string "PinballWizard" if you want to filter out this msg.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.