bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

User can sign up to receive the Mozilla Newsletter without checking the privacy policy box on FF OS

VERIFIED FIXED in 2015-01-20

Status

Marketplace
Consumer Pages
P1
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ValentinaP, Assigned: mat)

Tracking

Avenir
2015-01-20
x86_64
Gonk (Firefox OS)
Points:
---

Details

(Reporter)

Description

4 years ago
Steps to reproduce:
1. Sing in to MP-stage page on your Inari device
2. Load the Settings page
3. Go to “Newsletter” section and click the “Sign up for our newsletter” blue link
4. Click the “Sign me up” button

Expected results:
The message “Please check this box if you want to proceed” is displayed on top of the privacy policy checkbox.

Actual result:
User is signed up to receive the newsletter. The message “Thanks for signing up!You'll receive an email from mozilla@e.mozilla.org, please check your inbox for your first email from us. If you don’t see it, check your spam filter.” is displayed.

Notes/Issues:
Verified on FF OS 1.4 (Inari). Issue is also reproducing on FF OS 2.0 (Flame)
Not reproduced on desktop.
Ashes ID: fe2ae

Updated

4 years ago
Assignee: nobody → mpillard
Priority: -- → P1

Updated

4 years ago
Severity: normal → critical
Keywords: regression
(Assignee)

Comment 1

4 years ago
Was it ever verified working on Firefox OS phones by QA ? Seems weird that it would regress. The "required" attributes are present, so at the moment I don't understand what's going on and suspect a platform bug.
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

4 years ago
Not a regression: it never worked with Firefox OS.
Keywords: regression
(Assignee)

Comment 4

4 years ago
Fixed in https://github.com/mozilla/fireplace/commit/78b28e7f037168e8a159a884b130d50edc346c85

It was affecting all Firefox OS versions, because of bug 943869 - my fix is merely a workaround.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: 2015-01-13 → 2015-01-20
(Reporter)

Comment 5

4 years ago
Verified as fixed in MP-dev on FF OS 1.4(Inari) and FF OS 2.0(Flame).
Postfix screenshot http://screencast.com/t/yf3GeJxxXTN .
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.