If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

ServiceWorker Cache should set InternalRequest::SetSkipServiceWorker() in FetchPut.cpp

RESOLVED DUPLICATE of bug 1120501

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1120501
3 years ago
3 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
After bug 1119026 clients of FetchDriver must manually call InternalRequest::SetSkipServiceWorker().  This method must be called if Cache::Add() or Cache::AddAll() were initiated from a service worker.
(Reporter)

Comment 1

3 years ago
This one won't matter after I implement bug 1120501.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120501
You need to log in before you can comment on or make changes to this bug.