[Task Manager] Update background to dark grey

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::Window Mgmt
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: epang, Assigned: sfoster)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S6 (20feb)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Since we are not able to use the background planned for task manager can we update from black to dark gray #333333

Thanks!
(Reporter)

Comment 1

3 years ago
sorry wrong hex, please update to #5f5f5f
Thanks!
Blocks: 1033971
(Reporter)

Comment 2

3 years ago
(In reply to Eric Pang [:epang] from comment #1)
> sorry wrong hex, please update to #5f5f5f
> Thanks!

Sorry Sam, I made a mistake on the search app spec.  We should use #4d4d4d so the background is consistent.  Please ignore the other hex values above.  Thanks!
Flags: needinfo?(sfoster)
(Assignee)

Comment 3

3 years ago
Thanks Eric, noted.
Flags: needinfo?(sfoster)
(Assignee)

Comment 4

3 years ago
Created attachment 8553330 [details] [review]
GH Pull Request

Just swaps out the background color for the (apps-mode) task manager. Empty state and filtered/tab view is unchanged.
Attachment #8553330 - Flags: review?(etienne)
Comment on attachment 8553330 [details] [review]
GH Pull Request

found a nit :)
Attachment #8553330 - Flags: review?(etienne) → review+
(Reporter)

Comment 6

3 years ago
(In reply to Sam Foster [:sfoster] from comment #4)
> Created attachment 8553330 [details] [review]
> GH Pull Request
> 
> Just swaps out the background color for the (apps-mode) task manager. Empty
> state and filtered/tab view is unchanged.

Hey Sam,

Hold off landing this, there's a big change we're going to update the RB search background to #333333.  So we might have to update this too :).

Thanks!
(Reporter)

Comment 7

3 years ago
Marked dependent on bug 1125810.  This bug will update the background of the search app background to #333333.  The background of the task manager should match what we use in the RB search.
Depends on: 1125810
(Assignee)

Comment 8

3 years ago
Created attachment 8560620 [details]
taskmanager-bg.png

Screenshot of task manager with fully opaque #333 background color, and 85% opaque #333 for empty state
Attachment #8560620 - Flags: ui-review?(epang)
(Reporter)

Comment 9

3 years ago
Comment on attachment 8560620 [details]
taskmanager-bg.png

Thanks Sam, looks good to me!
Attachment #8560620 - Flags: ui-review?(epang) → ui-review+
(Assignee)

Comment 10

3 years ago
Merged to master: 
https://github.com/mozilla-b2g/gaia/commit/c568fb4e6732788c835c236147d34a6b02ca9bb7
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

3 years ago
Comment on attachment 8553330 [details] [review]
GH Pull Request

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Task Manager
[User impact] if declined: Inconsistency with colors used in Rocketbar/Search
[Testing completed]: On device, Gaia-Try
[Risk to taking this patch] (and alternatives if risky): Zero? CSS only patch that tweaks some background-colors
[String changes made]: None
Attachment #8553330 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8553330 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/a067732a071600574091abf1a5baed22918bd8a4
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S6 (20feb)
Duplicate of this bug: 1131764
Created attachment 8628651 [details]
verify.png

This bug has been verified as "pass" on latest build of Flame 2.2 & master,Nexus5 2.2 & master
STR.
Prerequisite:No app running in background.
1.Invoke Taskmanager then check background color.
2.Open an app.
3.Invoke Taskmanager then check background color.

Actually result:Background color is gray.
Reproduce rate: 0/10
See attachment: verify.png

Device: Flame 2.2 (pass):
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.195343
Firmware Date          Wed Jul  1 19:53:55 EDT 2015
Bootloader             L1TC000118D0

Device: Flame_master (pass):
Build ID               20150701160205
Gaia Revision          858764a56982eb558259ccc689bbee855f090085
Gaia Date              2015-07-01 16:59:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c36f68439496
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150701.193443
Firmware Date          Wed Jul  1 19:34:55 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5_2.2 (pass):
Build ID               20150701162502
Gaia Revision          bd386f346eb1591fddbc84bf034b22700e7e2a58
Gaia Date              2015-06-30 15:53:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/f16c1125b9d6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150701.195806
Firmware Date          Wed Jul  1 19:58:26 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5_master (pass):
Build ID               20150701160205
Gaia Revision          858764a56982eb558259ccc689bbee855f090085
Gaia Date              2015-07-01 16:59:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c36f68439496
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150701.193431
Firmware Date          Wed Jul  1 19:34:50 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
You need to log in before you can comment on or make changes to this bug.