Closed Bug 1120518 Opened 6 years ago Closed 6 years ago

Improved fonts for desktop reader mode

Categories

(Toolkit :: Reader Mode, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1139174

People

(Reporter: Margaret, Unassigned)

References

(Blocks 1 open bug)

Details

I'm splitting this off from bug 1117258, since font changes often have their own challenges, such as language support.

Also see bug 1119429 for the Android bug about this.
Actually, it looks like we don't even ship Clear Sans or Charis SIL on desktop at the moment, so this is a bigger problem that just Fira Sans.
Summary: Use Fira Sans for desktop reader mode → Improved fonts for desktop reader mode
Flags: firefox-backlog+
As a quicker fix, we can use font:message-box to get the default UI fonts for the platform.

That will be Helvetica Neue on OSX (Lucida Grande on earlier versions) and Segoe UI on Windows 7+ (Tahoma on earlier versions). I'm not sure what font is used on Linux with message-box, but it will be the same font that is used for the location bar by default.
Bug 1014208 has an optimized version of Fira Sans.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139174
You need to log in before you can comment on or make changes to this bug.