TSan: data race gfx/thebes/gfxPlatform.cpp:1767 GetRenderingIntent

RESOLVED DUPLICATE of bug 1120611

Status

()

RESOLVED DUPLICATE of bug 1120611
4 years ago
4 years ago

People

(Reporter: froydnj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8547754 [details]
tsan-gfx-race.txt

The attached logfile shows a thread/data race detected by TSan (ThreadSanitizer).

Typically, races reported by TSan are not false positives, but it is possible that the race is benign. Even in this case though, we should try to come up with a fix unless this would cause unacceptable performance issues. Also note that seemingly benign races can possibly be harmful (also depending on the compiler and the architecture) [1].

If the bug cannot be fixed, then this bug should be used to either make a compile-time annotation for blacklisting or add an entry to the runtime blacklist.

[1] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
I expect this is mostly benign. The global that's being shared is basically just an optimization. Having the function run multiple times shouldn't really be a big deal.

That being said, the right way to fix this is probably to always call GetRenderingIntent from the main thread and pass the information through.
Component: Graphics → ImageLib
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120611
> I expect this is mostly benign.

I expect I will be linking to this article frequently in the future:

https://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
Oh, it's mentioned in the boilerplate.
You need to log in before you can comment on or make changes to this bug.