If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Accessibility escape (scrub gesture) not available where convenient

RESOLVED FIXED

Status

()

Firefox for iOS
Browser
--
enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Boris Dušek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
bnicholson
: review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
When there is a situation where the user should be able to cancel what is on the screen (like pressing Esc on desktop) to go back to previous screen, VoiceOver users should be provided with the option to do this act of canceling through the VoiceOver scrub gesture.

It is basically a shortcut so that VoiceOver user does not have to go to the buttont that does the escape function, but can invoke it using scrub gesture from anywhere on the screen.

The current situations where this applies:
- when working in the tab bar view (i.e. when editing address or browsing bookmarks, settings), there is a Cancel button at the top whose function to dismiss the tab bar view should be available also using scrub gesture from anywhere in the tab bar view
- when in the browser view, the back button (to go one page back in history) should be invokable by the scrub gesture (a la Safari on iOS)

In code, this is done by implementing UIAccessibility.accessibilityPerformEscape
Created attachment 8552091 [details] [review]
Pull request
Attachment #8552091 - Flags: review+
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
There is a regression in this since this was fixed - this no longer works for going back in history when browsing a webpage.
(In reply to Boris Dušek from comment #2)
> There is a regression in this since this was fixed - this no longer works
> for going back in history when browsing a webpage.

Mind filing a new bug if not already?
You need to log in before you can comment on or make changes to this bug.