can't login to mail.yahoo.com

VERIFIED INVALID

Status

()

--
minor
VERIFIED INVALID
17 years ago
7 years ago

People

(Reporter: mighty_hektor, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

0.95 could login fine, as can netscape 4.78. This version of Mozilla just says
"Document finished" and stays at the login page.

Reproducible: Always
Steps to Reproduce:
1. go to mail.yahoo.com
2. try to login

Actual Results:  Mozila just sits there

Expected Results:  Should go to inbox or display "incorrect password"

Comment 1

17 years ago
Reporter: Did you install PSM?

Comment 2

17 years ago
WFM Build ID 2001112615 PC/Linux
(Reporter)

Comment 3

17 years ago
It's a nightly build from 20 November. I don't think PSM is required for an
insecure login (which yahoo is unless you choose secure explicitly) anyway, is
it?
(Assignee)

Comment 4

17 years ago
i'm using the same build 2001112012 (downloaded from
mozilla.org/pub/mozilla/nightly/latest0.9.6) and it works for me on RH71/gnome.

Is true that there are 2 options to login standard|secure but as soon as you
"Sign In" PSM is required in both cases.

reporter:
please verify again
thx

Comment 5

17 years ago
this should be a confirmed bug

Besides mail.yahoo.com, cannot sign-in on a
similar form to games.yahoo.com

Build 2001112012
Using Mandrake 8.0

(Assignee)

Comment 6

17 years ago
check your firewall settings guys. port 443 should not be blocked. i had
something similar before.
(Reporter)

Comment 7

17 years ago
No firewall here. Again, it worked fine with 0.95.

Does the precompiled 2001112012 have APM, Alexandru?
(Assignee)

Comment 8

17 years ago
APM? do u mean PSM?
Is built with PSM2 be cause is a distribution build. And it really works for me.
I can login on mail, games, geocities whatever comes from yahoo. I swear! :-)
(Assignee)

Comment 9

17 years ago
aw... just another question: is there maybe a proxy between your machine and yahoo?
(Reporter)

Comment 10

17 years ago
Yes, I meant PSM - excuse me!

No, no Proxy. As I said, it worked with moz .95 on the same machine. I'll revert
and see if I get yahoo back. If so, I'll know it's something other than the
browser.

Comment 11

17 years ago
Cookie settings?
(Assignee)

Comment 12

17 years ago
i installed the 0.9.6 from mozilla.org on my linux machine at home, and it works
too. (i just replaced the existent mozilla directory with the one from the
tarball - no installer needed)

Comment 13

17 years ago
*** Bug 113434 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

17 years ago
any news guys? still having problems with it?

Comment 15

17 years ago
Hi

testing on Windows NT I can't log in to Yahoo mail (mail.yahoo.com) either
(neither on Netscape 6 nor Mozilla 0.9.6).
On the same computer I can log in fine using Opera 5.01 so I don't think this is
an obvious proxy problem. I am connecting in unsecure mode in all browsers.
Before sending login to yahoo Mozilla tells me the security warning:
"You have requested an encrypted page. The website has identified itself
correctly, and information you see or enter on this page cannot be easily read
by a third party".
Then straight away I get
"You have requested an encrypted page that contains some unencrypted information.
Information that you see or enter on this page could easily be read by a third
party"

On Mozilla 0.9.6 (build ID 2001112009) the login is refused by yahoo and I get a
message from them about my browser not accepting cookies. On netscape 6 the
screen just freezes (and nothing happens) after clicking on "send login".

Then I get the login in page again. Again I type my userid password. This time
yahoo responds with a complaint about cookies and hasn't let me in to my mail
account

>The browser you're using refuses to sign in. (cookies rejected)
>We need to use "cookies" to identify you on our system. Try these steps
>• Just try signing again. If your browser asks you to accept cookies, choose
>"accept" each time.
>• Perhaps your browser is not set to allow cookies. Consult "Help" on your
>browser to find out how to change this setting.


I have my browser set up to ask me before accepting cookies (maybe that is the
problem?).
(Reporter)

Comment 16

17 years ago
You are having a different problem than I was. My Mozilla would say "Document
Done, .12 seconds [or whatever]," assuming that it had done everything that it
should have.

Your problem definately sounds like a cookie problem, whereas mine seems to have
been a result of a single build. I'm using Yahoo Mail on a build with the same
ID (2001112012) but built for the i686 arch instead of i386. That may or may not
have something to do with the fact that it works now...?

Comment 17

17 years ago
I just tried and was able to log in.

For testing, please do the following: Use profile manager (on Linux you can
start mozilla with argument -ProfileManager) and create yourself a separate
fresh new profile. Try to login to yahoo using that profile. Try both "secure"
and "standard" login modes. Please let us know whether that works.
(Assignee)

Comment 18

17 years ago
John:

Few questions:

- is it working now for you? 
- which build are you using now and where is it from?
- have you built the prvious non-working version on your own?
- which machine are you using and which Linux distribution?

thx
(Assignee)

Comment 19

17 years ago
PESANT Sylvain wrote:
> 
> Hello,
> 
> This is my differents tests
> 
> - Linux config:
> Debian 2.2r3, Mozilla (2000110321)
> I try your suggestion -ProfileManager create new
> profil doesn't work
> I try in standard mode doesn't work
> I can't try in secure mode because Mozilla stop me 
> immediatly "Can't make connection...."
> 
> - Win98 config:
> Mozilla 0.9.4 (2001091303)
> It's work fine in both mode standard and secure.
> 
> Linux config and Win98 config are home tests:
> This tests was made under the same hardware and same
> provider
> by modem
> 
> Tommorow I'll try your suggestions in my work place 
> with other OS and Mozilla versions
> NT4, Mozilla 0.9.6
> May be w2k, Mozilla 0.9.6
> 
> This problem was appear suddenly in morning working
> fine
> and afternoon can't login I try it in three differents
> places
> hardware and providers
> 
> - Home
> - Work
> - Laptop
> 
> I think yahoo change theirs servers configuration and
> now Mozilla can't acces.
> 
> Thanks for your help
> 

Comment 20

17 years ago
i have the exact same problems.
ive tried using old versions of mozilla with no luck.
oddly enough: netscape 6.2 works, i dont know why.

Comment 21

17 years ago
The psm-related issue is really a number of bugs:

1) Mozilla should put up an error dialog when psm is not installed and one tries
to access a secure (https) web page.  It currently does nothing but show
"Document: Done (0.012 secs)" in the ststus bar.  This makes it very difficult
to troubleshoot this problem.

2) The documentation suggests that recent mozilla builds are bundled with psm. 
While this is apparently true for tarballs, there is a seperate rpm for
mozilla-psm.  So, it's unclear to the end user that this has to be installed
seperately.

3) I'm no expert on rpms, but can't they contain information about mandatory or
suggested package dependencies?  If so, the mozilla rpm should at least have a
suggested dependency on the mozilla-psm package.
(Assignee)

Comment 22

17 years ago
mike:
good hints! coould you please check the installer bugs and see if there are
already  bugs posted about this issues? could you please open a bug for them? thanx!
(Reporter)

Comment 23

17 years ago
I installed via a precompiled tarball, not the RPM. BTW, I don't think RPMs have
"suggested" dependencies - only required ones. I'm no expert either, but I've
never seen such a thing.

That error (Done: 0.012 seconds) is exactly what I was getting, down to the
character. It came up right away (0.012 seconds, right? :) strongly suggesting a
bug.

Comment 24

17 years ago
there are bug 47617 and bug 86486 on the issue, and PSM issues regarding this
was specifically mentioned the 0.9.5 release notes. Vanished again in release
notes for 0.9.6 for some reason.

Comment 25

17 years ago
*** Bug 114207 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
*** Bug 114441 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
I am getting almost the same failure on mail.yahoo.com & play.yahoo.com signon
pages. Mozilla crashes immediately after clicking the submit button and it
happens EVERY time for me. I am on Win2k Pro, and it's happened with builds
20011212xx and 20011214xx. (the build I had prior to that, which I don't
remember) worked OK. 

Comment 28

17 years ago
Yesterday I installed 0.9.6

I cannot log in to Yahoo mail.  As decribed in the orignal 
bug report. the login just hangs.

I can then bring immediately bring up netscape 4.78, and
log in with no trouble.

Comment 29

17 years ago
You can't login anywhere in Yahoo.
http://www.liverpoolfc.tv is broken too.

What do they have in common? https login.

Hack the source and remove the 's' and you can log in to Yahoo again. Why did
no-one notice that you can't log into the world's most popular website?

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9.8

Comment 30

17 years ago
If you're one of the people seeing this bug and you are sure that you have a
build with PSM installed can you please add this information:

latest BuildID tested:
OS:
Hardware (processor type and speed):
specific URLs that fail:

Thanks.

Comment 31

17 years ago
I think I now understand the problem. I believe it is a Yahoo! bug.

The problem does only appear, when the security component is not installed.

When you go to http://mail.yahoo.com, not changing anything, the page says
"Mode: Standard", with the option to click on Secure (a link pointing to https).

But that's an option. If you *not* click on Secure, I'd expect that the form
should be submitted in the insecure mode, without using https, just plain http.

But looking at the page source, you can clearly see that the form action points
to an https URL. And that will simply fail without having PSM installed, as in
that case https is an unknown protocol.

I just tested that with an installation of Mozilla 097, without having PSM
installed. When I try to submit the form, I get the error message "Unknown
socket type. Loading aborted.".

It works for me when I have PSM installed.

Note that in bug 114441, Georg also said that installing PSM solved his problem.

Somebody should evangelize the mail.yahoo.com webmasters to fix their page.

Setting to INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 32

17 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.