Closed Bug 1120976 Opened 8 years ago Closed 7 years ago

whatsnew page not showing for Mac

Categories

(Toolkit :: Application Update, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox35 + affected

People

(Reporter: bhearsum, Unassigned)

Details

This was found when doing final testing for 35.0. KaiRo told me that Mac users were not getting WN pages shown, while other platforms were. The xml in place looked like:
<updates>
<update type="minor" displayVersion="35.0" appVersion="35.0" platformVersion="35.0" buildID="20150108202552" detailsURL="https://www.mozilla.com/en-US/firefox/35.0/releasenotes/" actions="showURL" openURL="https://www.mozilla.org/en-US/firefox/35.0/whatsnew/?oldversion=%OLD_VERSION%">
<patch type="complete" URL="http://download.mozilla.org/?product=firefox-35.0-complete&os=osx&lang=en-US" hashFunction="SHA512" hashValue="b8ce4d05efecb68d4ea00b1c06509b60eef3030534ebaa270dc92fe6bf149ab481f29e7910cb6b444d6ffbc3ea126055be76ee0ad09ac72fe295196ebb67e022" size="70657407"/>
</update>
</updates>

...which looks correct to me, and watches what we had for Windows.
Catalin originally found this issue in spot testing on where we show WN pages or not for the 35 update.
Likely caused by Mac v2 signing and the requirement to move the updates.xml file outside of the bundle. I'll verify whether it is self correcting which it should be otherwise tests would be failing.
OS: Linux → Mac OS X
I'm tracking for 35 in case we decide that we need at 35.0.1 so that we can consider taking a fix.
I just verified that updating from 34.0 using the xml to update to 35.0 with the following added:
actions="showURL" openURL="https://www.mozilla.org/en-US/firefox/35.0/whatsnew/?oldversion=%OLD_VERSION%"

and it opened the url.

Updating from before Mac v2 signing didn't open the url due to the Mac v2 signing work.
If we do a 35.0.1 do we need a patch nominated here moving the updates.xml file?
Flags: needinfo?(robert.strong.bugs)
Most systems have already updated to 34 (> 80%) and only systems prior to 34 are affected by this bug. I don't think the value vs. risk and time taken from other work is great enough to try to fix this for the remaining Macs affected by this bug which quickly estimated would be at most 3 million users and likely quite a bit less.
Flags: needinfo?(robert.strong.bugs)
Since there is plenty of other work to do and most users have already updated to a version that has Mac v2 signing where this doesn't happen resolving as wontfix
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.