Closed Bug 1120999 Opened 7 years ago Closed 7 years ago

[gonk-l] Compile error in gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferQueueConsumer.cpp

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1119980

People

(Reporter: seinlin, Unassigned)

References

Details

Attachments

(1 file)

gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferQueueConsumer.cpp
In file included from /frameworks/native/include/binder/IInterface.h:21:0,
                 from /gecko/widget/gonk/nativewindow/IGonkGraphicBufferConsumerLL.h:27,
                 from /gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferItem.h:21,
                 from /gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferQueueConsumer.cpp:24:
/frameworks/native/include/binder/Binder.h:35:25: error: 'virtual android::status_t android::BBinder::dump(int, const android::Vector<android::String16>&)' was hidden [-Werror=overloaded-virtual]
     virtual status_t    dump(int fd, const Vector<String16>& args);
                         ^
In file included from /gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferQueueConsumer.cpp:25:0:
/gecko/widget/gonk/nativewindow/GonkBufferQueueLL/GonkBufferQueueConsumer.h:140:18: error:   by 'virtual void android::GonkBufferQueueConsumer::dump(android::String8&, const char*) const' [-Werror=overloaded-virtual]
     virtual void dump(String8& result, const char* prefix) const;
                  ^
cc1plus: all warnings being treated as errors
Hi Sotaro, Could you review this patch? Thanks!
Attachment #8548265 - Flags: review?(sotaro.ikeda.g)
Hi Kai-Zhen Li, there seems already Bug 1119980. Patches in Bug 1119980 seems already include a change of attachment 8548265 [details] [diff] [review]. What is a relationship to Bug 1119980?
Flags: needinfo?(kli)
Sotaro, Thanks!
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(kli)
Resolution: --- → DUPLICATE
Duplicate of bug: 1119980
Attachment #8548265 - Flags: review?(sotaro.ikeda.g)
You need to log in before you can comment on or make changes to this bug.