Closed Bug 1121052 Opened 5 years ago Closed 4 years ago

about:tabcrashed displays at the zoom level of the crashed page

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 43
Tracking Status
e10s m8+ ---
firefox43 --- fixed

People

(Reporter: mossop, Assigned: mrbkap)

Details

Attachments

(1 file, 1 obsolete file)

The zoom level of the page that crashed is retained when showing the about:tabcrashed UI, we should reset the zoom level in this case.
Assignee: nobody → mrbkap
Attached patch Patch v1 (obsolete) — Splinter Review
This seems to do the trick. I don't know how to write a test for it, though.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=71c518a8a2a3
Attachment #8657337 - Flags: review?(dtownsend)
Comment on attachment 8657337 [details] [diff] [review]
Patch v1

Review of attachment 8657337 [details] [diff] [review]:
-----------------------------------------------------------------

I'd like to see a test for this before reviewing, browser_crashedTabs.js has a number of tests of this page that you should be able to work from.

::: browser/base/content/browser.js
@@ +1142,5 @@
>        });
>  #endif
> +
> +      // Reset the zoom for the tabcrashed page.
> +      ZoomManager.setZoomForBrowser(browser, 1);

Does this end up resetting the zoom level for this site even after being crashed?
Attachment #8657337 - Flags: review?(dtownsend)
Attached patch Patch v1.1Splinter Review
I tried Felipe's suggestion from comment 3 and it doesn't work. I think that's because we don't actually send a locationchange event when we load about:tabcrashed (otherwise, we wouldn't need the custom AboutTabCrashedLoad event).

I tested that we restore the zoom level correctly.
Attachment #8657337 - Attachment is obsolete: true
Ah ok, fair. Thanks for testing that!
Attachment #8658455 - Flags: review?(dtownsend)
Comment on attachment 8658455 [details] [diff] [review]
Patch v1.1

Review of attachment 8658455 [details] [diff] [review]:
-----------------------------------------------------------------

Great, thanks for the test
Attachment #8658455 - Flags: review?(dtownsend) → review+
https://hg.mozilla.org/mozilla-central/rev/eab8b499b5ed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
QA Whiteboard: [good first verify]
I have reproduced this bug on Nightly 38.0a1(2015-01-13) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Aurora 44.0a2!

Build ID: 20151029045227
User Agent: Mozilla/5.0 (X11; Linux i686; rv:44.0) Gecko/20100101 Firefox/44.0

[testday-20151030]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.