Should use sockit-to-me built in socket timeout mechanism

RESOLVED DUPLICATE of bug 1104285

Status

Testing
JSMarionette
RESOLVED DUPLICATE of bug 1104285
3 years ago
3 years ago

People

(Reporter: aus, Assigned: aus)

Tracking

unspecified
B2G C4 (2jan on)
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

3 years ago
We should use sockit-to-me's built in socket poll timeout during waitForSocket.
(Assignee)

Comment 1

3 years ago
Created attachment 8548501 [details] [review]
Pull Request - Use sockit-to-me built in socket timeout to avoid socket misuse.

Need to wait for sockit-to-me update before landing this.
Attachment #8548501 - Flags: review?(jlal)
Comment on attachment 8548501 [details] [review]
Pull Request - Use sockit-to-me built in socket timeout to avoid socket misuse.

lgtm
Attachment #8548501 - Flags: review?(jlal) → review+
(Assignee)

Updated

3 years ago
Whiteboard: [systemsfe]
(Assignee)

Comment 3

3 years ago
Commit (master): https://github.com/mozilla-b2g/marionette-js-client/commit/ed62fd839067e3f6d6aef4f3996e953f0a54306a

Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

3 years ago
There are issues with this change. I have a new Pull Request with more a more appropriate change -- https://github.com/mozilla-b2g/marionette-js-client/pull/127.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

3 years ago
Created attachment 8549268 [details]
Pull Request - Better interval, timeout and socket timeout.
Attachment #8549268 - Flags: review?(kgrandon)
Comment on attachment 8549268 [details]
Pull Request - Better interval, timeout and socket timeout.

Ok, let's try this dance again.

In master: https://github.com/mozilla-b2g/marionette-js-client/commit/b56005095764d8b6ad2858e429fafd10ee89fec9

Version bumped to 1.5.4: https://github.com/mozilla-b2g/marionette-js-client/commit/095617c4afb50fb28d4aad3d9ca81537e06a62a5
Attachment #8549268 - Flags: review?(kgrandon) → review+
Nope, this is still failing in gaia-try: https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=6c0adedd635f

Going to backout the packages, and recommend we test on gaia-try before doing the module dance again.
Flags: needinfo?(aus)
Blocks: 1120508
(Assignee)

Comment 8

3 years ago
Here's the latest test run that's going:

https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=df238f6c73c5

I think my changes to the Makefile weren't complete enough for other test runs and it would still try and pull the wrong versions from mozilla-b2g instead of my own repository for gaia-node-modules.

Otherwise, I'm not seeing any failures that are new. Only existing intermittents. Said intermittents are *not* failing because of lack of connecting or timeouts. That's promising.
Flags: needinfo?(aus)
(Assignee)

Comment 9

3 years ago
Created attachment 8550415 [details] [review]
Pull Request - As tested on gaia-try.

I'll set the review flag on this as soon as the gaia-try runs look good.
(Assignee)

Updated

3 years ago
Attachment #8548501 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Attachment #8549268 - Attachment is patch: true
Attachment #8549268 - Attachment mime type: text/x-github-pull-request → text/plain
(Assignee)

Updated

3 years ago
Attachment #8549268 - Attachment is obsolete: true
Attachment #8549268 - Attachment is patch: false
(Assignee)

Comment 10

3 years ago
We're going to land this as part of bug 1104285.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1104285
You need to log in before you can comment on or make changes to this bug.