Intermittent uninstallation_test.js | Show Keyboard App after uninstallation "before each" hook

RESOLVED FIXED

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: kgrandon, Assigned: rudyl)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Filing a new bug to clean up the previous work

b2g_ubuntu64_vm b2g-inbound opt test gaia-js-integration-1

http://ftp.mozilla.org/pub/mozilla.org/b2g/try-builds/gaiabld-71a206c7bf25/gaia-try-linux64_gecko/gaia-try_ubuntu64_vm-b2gdt_test-gaia-js-integration-1-bm117-tests1-linux64-build773.txt.gz

03:49:31 INFO - TEST-UNEXPECTED-FAIL | apps/keyboard/test/marionette/uninstallation_test.js | Show Keyboard App after uninstallation "before each" hook
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1108578
(Reporter)

Comment 2

4 years ago
Rudy - could you get someone to investigate this intermittent test?
Flags: needinfo?(rlu)
I'll take a look, thanks for the heads-up.
Assignee: nobody → rlu
Status: NEW → ASSIGNED
Flags: needinfo?(rlu)
Created attachment 8548837 [details] [review]
Patch V1

Hope this could resolve this issue.

Kevin, just use waitForElement instead of findElement to locate a specific element, could you help review this?

I tried to retrigger the test jobs and all of them passed.
Thanks.
Attachment #8548837 - Flags: review?(kgrandon)
(Reporter)

Comment 5

4 years ago
Comment on attachment 8548837 [details] [review]
Patch V1

This makes sense to me. Let's land it and see if we notice it anymore.
Attachment #8548837 - Flags: review?(kgrandon) → review+
(Reporter)

Comment 6

4 years ago
I've re-named the commit and landed with you as the author to try to save you some time - hope that's ok. In master: https://github.com/mozilla-b2g/gaia/commit/bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
It seems the above fix did not fix the issue completely, I've seen intermittent failure like this one,
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=807aa3efeb68

Let's re-open this bug and I'll spend some time to investigate.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
Created attachment 8556846 [details] [review]
Patch 2

Another try to resolve this intermittent failure.
Now we would wait for the 2nd input window to show up and then switch to it in case the 2nd one is not loaded yet and caused that we switched to the first one (the built-in keyboard).

Also refined the code for checking "," key when there shouldn't be IME switching key.

Tim, could you please help review this?
Thank you.
Attachment #8556846 - Flags: review?(timdream)
Comment on attachment 8556846 [details] [review]
Patch 2

Thanks!
Attachment #8556846 - Flags: review?(timdream) → review+
Landed Patch 2 to master,
https://github.com/mozilla-b2g/gaia/commit/190bc73c4258c69497ea8df3c2c707a614e1d4b8


--
Thanks for the review.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
Created attachment 8559167 [details]
Not clickable button

This patch still fails locally (against gaia/master), and also fails on try for bug 1126012...
Flags: needinfo?(rlu)
So the issue is that the delete confirm dialog has lower z-index than the keyboard, thus marionette can't click on it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 8559200 [details] [review]
[PullReq] comoyo:bug1121274 to mozilla-b2g:master
Created attachment 8559202 [details] [review]
Patch 3

Tim/Rudy, this patch blurs the input field first so the keyboard frame doesn't have higher z-index than the dialog.
Attachment #8559200 - Attachment is obsolete: true
Flags: needinfo?(rlu) → needinfo?(timdream)
Attachment #8559202 - Flags: review?(rlu)
Looks good, Rudy can review this.
Flags: needinfo?(timdream)
Comment on attachment 8559202 [details] [review]
Patch 3

The issue you're trying to resolve is Bug 1129541, which is not the same as this issue.

For this bug, the failure is in check3rdPartyIme() that it could not locate the sendKey button due to wrong timing to switch to new IME app.

For Bug 1129541, let's move the discussion there.
Thanks.
Attachment #8559202 - Flags: review?(rlu)
The new perma-red issue should be tracked by Bug 1129541 instead of this bug because the root cause is quite different.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You can safely disregard all the TBPLbot comments above. Gij was recently unhidden and a lot of older jobs were classified.

That said, any newer ones after this point should be cause for concern :)
(Reporter)

Comment 32

3 years ago
Going to move the intermittent-failure keyword over to bug 1129541. Seems like this test is being handled there.
Keywords: intermittent-failure
Blocks: 1136683
Duplicate of this bug: 1136698
You need to log in before you can comment on or make changes to this bug.