Closed Bug 1121331 Opened 5 years ago Closed 5 years ago

Vsync aligned refresh timer

Categories

(Core :: Graphics, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla38
Tracking Status
firefox36 --- wontfix
firefox37 --- wontfix
firefox38 --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: jerry, Assigned: jerry)

References

Details

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1119742 +++

From bug 1092978:
attachment 8548078 [details] [diff] [review], Part3: [Silk] PVsync protocol for vsync event passing. v5, r=bent
attachment 8548137 [details] [diff] [review], Part6-1: [Silk] Vsync aligned refresh timer. r=roc,mchang
attachment 8548140 [details] [diff] [review], Part6-2: [Silk] VsyncChild actor and VsyncRefreshTimer creation. r=roc,bent

land these patchs as this bug
Successful try - https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e02db534772
Comment on attachment 8548721 [details] [diff] [review]
Part1: PVsync protocol for vsync event passing. r=bent

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: a part of silk, bug 987532.
Testing completed:
landed in m-c. m-c https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e02db534772
Risk to taking this patch (and alternatives if risky): small, we don't turn on the pref by default.
String or UUID changes made by this patch: none
Attachment #8548721 - Flags: approval-mozilla-b2g37?
Comment on attachment 8548722 [details] [diff] [review]
Part2: Vsync aligned refresh timer. r=roc,mchang

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: a part of silk, bug 987532.
Testing completed:
landed in m-c. m-c https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e02db534772
Risk to taking this patch (and alternatives if risky): small, we don't turn on the pref by default.
String or UUID changes made by this patch: none
Attachment #8548722 - Flags: approval-mozilla-b2g37?
Comment on attachment 8548723 [details] [diff] [review]
Part3: VsyncChild actor and VsyncRefreshTimer creation. r=roc,bent

[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: a part of silk, bug 987532.
Testing completed:
landed in m-c. m-c https://treeherder.mozilla.org/#/jobs?repo=try&revision=8e02db534772
Risk to taking this patch (and alternatives if risky): small, we don't turn on the pref by default.
String or UUID changes made by this patch: none
Attachment #8548723 - Flags: approval-mozilla-b2g37?
Attachment #8548721 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8548722 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8548723 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.