SIM signal icon doesn't indicate SIM number during FTE

VERIFIED FIXED in 2.2 S5 (6feb)

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: mikehenrty, Assigned: mikehenrty)

Tracking

unspecified
2.2 S5 (6feb)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 affected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(5 attachments)

1.) Insert 1 sim into phone.
2.) Flash phone with FTE enabled.
3.) Click next on the language selection screen.

Expected result:
Statusbar signal icon indicates which SIM number the signal bar represents.

Actual result:
The SIM number is missing from the signal icon.

Note, if the user then clicks "Back" and "Next" again, the SIM number mysteriously appears.
I believe showing the SIM number with signal in the statusbar during FTE is a partner requirement. Not sure if this applies anymore, but nomming just in case.
blocking-b2g: --- → 2.2?
Is this a regression?
Keywords: qawanted
QA Contact: ktucker
QA Contact: ktucker → bzumwalt
Issue occurs on Flame 2.1 & Flame 3.0

In FTU the SIM signal icon is missing SIM slot number

Device: Flame 2.1
BuildID: 20150114001300
Gaia: 6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko: 6600eba54256
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 3.0 Master
BuildID: 20150114010205
Gaia: e2a0f7c311119d4a8e160bdfb9e28a0e61a180fc
Gecko: 63006936ab99
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Unable to check 2.0 or V18D-1 base as the cell signal does not appear in FTU in those branches
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I think this should be fixed by bug 1115829. Is related to the fact that mozElements are not updated on aPNG changes (bug 1114526).

Adding qawanted to verify is fixed.
Keywords: qawanted
regression
blocking-b2g: 2.2? → 2.2+
Issue still occurs on Flame 3.0, 2.2, and 2.1

In FTU the SIM signal icon is missing SIM slot number for first two screens.

Device: Flame 3.0 Master
BuildID: 20150115010229
Gaia: bcc76f93f5659ac1eb8a769167109fd2d7ca4fbd
Gecko: c1f6345f2803
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2
BuildID: 20150115002505
Gaia: 7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko: ce27f2692382
Version: 37.0a2 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1
BuildID: 20150115001207
Gaia: 8d4846d7bec777046dc5e3d2b8005adb1370f1f7
Gecko: 8eb9bc3a945a
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
I can't reproduce this issue with the latest master. Please check if the problem is solved
Keywords: qawanted
Issue still occurs on latest Flame 3.0 Master 

In FTU the SIM signal icon is missing SIM slot number for first two screens. Tested on both shallow and full flash.

Device: Flame 3.0 Master
BuildID: 20150116010205
Gaia: 401e981f51cf047292d101c785be8ec48bf75e8c
Gecko: cac6192956ab
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (3.0 Master)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Alberto, can you take a look here?
Flags: needinfo?(apastor)
Assignee: nobody → apastor
Flags: needinfo?(apastor)
I can't repro... I tried with 1 SIM in slot 1, 1 SIM in slot 2, and 2 SIMs. I can see the slot number in all cases. Not sure what to do. Michael, any idea?

Gaia-Rev        0f65b258bceddd9d479b3c027d9bd234c1e99aaf
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/6446c26b45f9
Build-ID        20150119010205
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
Flags: needinfo?(mhenretty)
I'll take this.
Assignee: apastor → mhenretty
Flags: needinfo?(mhenretty)
Comment on attachment 8556216 [details] [review]
[PullReq] mikehenrty:bug-1121349-update-visibility to mozilla-b2g:master

Let's have Guillaume take the first look at this one.
Attachment #8556216 - Flags: review?(gmarty)
Comment on attachment 8556216 [details] [review]
[PullReq] mikehenrty:bug-1121349-update-visibility to mozilla-b2g:master

Looks good! Thanks for fixing that.
Attachment #8556216 - Flags: review?(gmarty) → review+
Comment on attachment 8556216 [details] [review]
[PullReq] mikehenrty:bug-1121349-update-visibility to mozilla-b2g:master

Thanks Guillaume. Now let's get a superreview for autolander.
Attachment #8556216 - Flags: review+ → review?(alive)
Comment on attachment 8556216 [details] [review]
[PullReq] mikehenrty:bug-1121349-update-visibility to mozilla-b2g:master

Thanks
Attachment #8556216 - Flags: review?(alive) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8556216 [details] [review]
[PullReq] mikehenrty:bug-1121349-update-visibility to mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 1035250.

[User impact] if declined:
User will see a SIM signal without the SIM number even in multi sim devices. The number will eventually show up, so the UX is confusing for FTU.

[Testing completed]:
Manually tested, added unit test.

[Risk to taking this patch] (and alternatives if risky):
Small fix which makes sure we update the StatusBar more often. Low risk.

[String changes made]: none.
Attachment #8556216 - Flags: approval-gaia-v2.2?
Attachment #8556216 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on Flame 3.0 and Flame 2.2 nightly builds.

Results: The SIM number is listed correctly in the FTE.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150212010213
Gaia: d5a71cedb37dd45f439f672489db3994b349ac43
Gecko: 3094601af679
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150212002504
Gaia: 791e53728cd8018f1d7cf7efe06bbeb1179f0370
Gecko: 5dec207fcbeb
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.