Closed Bug 1121358 Opened 7 years ago Closed 7 years ago

[font] Missing glyphs for South African market in default font Firefox OS

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1126641

People

(Reporter: friedel, Assigned: padamczyk)

References

Details

The default font on Firefox OS doesn't cover all the South African languages. 10 glyphs necessary for Venda (ve) is not there. We're not currently targeting that language, but since we are targeting South Africa, I think it would be good if others can correctly view names, for example (Venda people will probably have to use the English UI, but might still want to see the characters correctly displayed).

Here is a list of the characters, as shown in the table on http://salanguages.com/tshivenda/characters.htm
Latin capital D with circumflex below 	Ḓ	1E12
Latin small letter D with circumflex below 	ḓ	1E13
Latin capital L with circumflex below 	Ḽ	1E3C
Latin small letter L with circumflex below 	ḽ	1E3D
Latin capital N with dot below 	Ṅ 	1E46
Latin small letter N with dot below 	ṅ 	1E47
Latin capital N with circumflex below 	Ṋ 	1E4A
Latin small letter N with circumflex below 	ṋ 	1E4B
Latin capital T with circumflex below 	Ṱ	1E70
Latin small letter T with circumflex below 	ṱ	1E71

Arky, Chris Hofmann recommended that I CC you for input. Any idea how to go ahead with this?
Blocks: 1121352
Thanks for flying this bug, Friedel. Let me bring Patryk Adamczyk into this conversation as well. 

Patryk, Do you we have any definite road plans for covering all South African locales in the default Fira.
Flags: needinfo?(padamczyk)
Thanks for filing this bug, Friedel. Let me bring Patryk Adamczyk into this conversation as well. 

Patryk, Do you we have any definite road plans for covering all South African locales in the default Fira.
We are designing those glyphs right now, should be done in Q1. I'll take this bug and mark it fixed when we have a patch ready.
Assignee: nobody → padamczyk
Flags: needinfo?(padamczyk)
Thanks Patryk!
Depends on: 1126641
[Blocking Requested - why for this release]:
Many locales in Africa are going to ship soon, on 2.0 (see mana for details https://mana.mozilla.org/wiki/display/PM/Firefox+OS+Wave+Launch+Cross+Functional+View)

Given the dates we've heard from Bus Dev, any work needed should be ready soon. Any ETA on this please?

Also, nominating for 2.0.
blocking-b2g: --- → 2.0?
[Triage]

For partner working with FxOS 2.0, TAM has communicated to them to handle "languages other then what are already supported in FxOS 2.0" by their own, so this will not block 2.0.

De-mon it from 2.0.
blocking-b2g: 2.0? → ---
This should already be resolved by Fira v.4.002 which landed in master. I will mark this a duplicate of the bug that is insuring Fira lands on 2.0.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1126641
You need to log in before you can comment on or make changes to this bug.