If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Bluetooth][File Transfer] Abstract FileTransfer module to expose send()/receive() methods simply in system app.

REOPENED
Unassigned

Status

Firefox OS
Gaia::Bluetooth
REOPENED
3 years ago
2 years ago

People

(Reporter: gasolin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
followup of bug 1115622, decouple bluetoothTransfer handover file with NFC handover manager via event
(Reporter)

Updated

3 years ago
Blocks: 1093084

Comment 1

3 years ago
Created attachment 8549311 [details] [review]
[PullReq] gasolin:issue-1121359 to mozilla-b2g:master
(Reporter)

Comment 2

3 years ago
done by bug 1092894
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092894
(Reporter)

Comment 3

3 years ago
reuse the bug, quote from ian on bug 1090799 comment 27, 

```
we also have discussion and plan to move file transfer relative work to another module. And the module is able to handle file transfer via Bluetooth/Wifi(if needed) in long tern. We won't do so much Bluetooth file transfer pre-process(get adapter/pair/getPairedDevices/connect) in |nfc_handover_manager| module.
```

1. add a nfc_handover_transfer proxy to isolate bt/wifi transfer
2. delegate real BT transfer to bluetooth_core/bluetooth_nfc_transfer
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Updated

3 years ago
No longer blocks: 1093084
Depends on: 1090799
Rename the bug title to clarify the gaol of this bug.
Summary: [Bluetooth] decouple bluetoothTransfer handover file with NFC handover manager → [Bluetooth][File Transfer] Abstract FileTransfer module to expose send()/receive() methods simply in system app.
Take over the issue since major task is relative with the process of Bluetooth file transfer.
Assignee: nobody → iliu
Assignee: iliu → nobody
You need to log in before you can comment on or make changes to this bug.