[Flame][Homescreen]The shortcut name will change to original name after you restart device.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Homescreen
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Lance(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8548731 [details]
logcat_1626.txt

[1.Description]:
[Flame][v2.2][Homescreen]Add facebook/twitter shortcut to Home, change the name, restart device, the name will change to original name.
Found time:16:26
See attachment:1626.mp4 and logcat_1626.txt

[2.Testing Steps]: 
1.Launch Socail.
2.Launch Facebook/Twitter.
3.Log in account, tap Menu, add the shortcut to Home.
4.Back to Home, long tap the shortcut, then change the name and save it.
5.Restart device, view the shortcut name.

[3.Expected Result]: 
5. The shortcut name should remain changed.

[4.Actual Result]: 
5. The shortcut name changes to the original one. 

[5.Reproduction build]: 
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150113162504
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150113.194114
FW-Date         Tue Jan 13 19:41:25 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

4 years ago
Created attachment 8548734 [details]
1626.MP4

Comment 2

4 years ago
Hi, Lance,

Could you do a branch check (latest v2.1 & v2.0)?
Thank you!
Flags: needinfo?(liuke)
(Reporter)

Comment 3

4 years ago
(In reply to William Hsu [:whsu] from comment #2)
> Hi, Lance,
> 
> Could you do a branch check (latest v2.1 & v2.0)?
> Thank you!

Hi William,
This bug still exist in latest Flame 2.2 build, but this issue has been verified successfully on Flame 2.0 and 2.1.

Steps:
1.Launch Socail.
2.Launch Facebook/Twitter.
3.Log in account, tap Menu, add the shortcut to Home.
4.Back to Home, long tap the shortcut, then change the name and save it.
5.Restart device, view the shortcut name.

[3.Expected Result]: 
5. The shortcut name should remain changed.

[4.Actual Result]: 
5. The shortcut name changes to the original one. 

== Build Information - 2015-1-15 (Issue could be found on this build) ==
Flame 2.2 version:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.040029
FW-Date         Wed Jan 14 04:00:40 EST 2015
Bootloader      L1TC000118D0

Fail rate:5/5

== Build Information - 2015-1-15 (Without this issue)==
Flame 2.1 version:
Gaia-Rev        6957ac8a322234ec99c8abb7cc18dc6a2e0176db
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6600eba54256
Build-ID        20150114001300
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.035135
FW-Date         Wed Jan 14 03:51:46 EST 2015
Bootloader      L1TC000118D0

Flame 2.0 version:
Gaia-Rev        31d6c9422cd0a8213df9f96019c9ab7168ec3ab3
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f2b6017e84eb
Build-ID        20150114000207
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150114.032626
FW-Date         Wed Jan 14 03:26:37 EST 2015
Bootloader      L1TC000118D0

Fail rate:0/5
Flags: needinfo?(liuke) → needinfo?(whsu)
(Reporter)

Updated

4 years ago
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → unaffected

Comment 4

4 years ago
Thanks Lance! :)

I think this is a regression bug.
Flags: needinfo?(whsu)
Keywords: regressionwindow-wanted
QA Contact: ktucker
Gecko Regression Window:

Last working Gecko mozilla-inbound build:

Environmental Variables:
Device: Flame 2.2
BuildID: 20141218003408
Gaia: 7a865bd6163e9a0372861d27450b3434875ef5c1
Gecko: 119ce28762a9
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken Gecko mozilla-inbound build:
Broken:

Environmental Variables:
Device: Flame 2.2
BuildID: 20141218011108
Gaia: 7a865bd6163e9a0372861d27450b3434875ef5c1
Gecko: 39e167bbd14c
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Working Gaia with Broken Gecko issue DOES occur:
Gaia: 7a865bd6163e9a0372861d27450b3434875ef5c1
Gecko: 39e167bbd14c

Working Gecko with Broken Gaia issue does NOT occcur:
Gaia: 7a865bd6163e9a0372861d27450b3434875ef5c1
Gecko: 119ce28762a9

Gecko Mozilla-Inbound Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=119ce28762a9&tochange=39e167bbd14c

Most likely due to bug 970307
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
NI on patch author, can you please take a look?  Looks like the patch for bug 970307 caused this issue.
Blocks: 970307
Flags: needinfo?(pbylenga) → needinfo?(kk1fff)
I'll take a look these day. Keeping ni for reminding.
Lance, I tested follow the STR in comment 3 against current central and the version you found was failure:

Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75

But I couldn't reproduce the problem. And I can't open the attached video. Could you upload the video again?
Flags: needinfo?(kk1fff) → needinfo?(liuke)

Comment 9

4 years ago
(In reply to Patrick Wang (Chih-Kai Wang) (:kk1fff) from comment #8)
> Lance, I tested follow the STR in comment 3 against current central and the
> version you found was failure:
> 
> Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
> Gecko-Rev      
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
> 
> But I couldn't reproduce the problem. And I can't open the attached video.
> Could you upload the video again?

Thanks for your help!

Video on youtube. FYI.
- http://youtu.be/VjNaA4cnbEI
Flags: needinfo?(liuke)

Comment 10

4 years ago
NI?whsu to reproduce it.
Flags: needinfo?(whsu)
I'm still not able to reproduce the bug. My build is the same as I mentioned in comment 8, and my STR is
1. Refresh image,
2. Go to Social
3. Tap 'twitter'
4. Tap menu on the up right corner
5. Tap 'Add to homescreen'
6. Without any change, tap 'Done'
7. Go to home screen, long press 'Welcome to facebook' icon.
8. Change its name to 'fb', then tap 'Done'
9. Back to home, tap home button again to exit modifying icon
10. restart.

tried on 319mb configuration.

Comment 12

4 years ago
Hi, Patrick,

I can reproduce this bug by using Build - 20150113162504 (v2.2).
I will discuss this bug with you later.
Many thanks.
Flags: needinfo?(whsu)
I can reproduce this on any recent PVT build images. Also I find the preallocated process in recent PVT image is quite large in terms of USS, its memory it uses is as large as memory of preallocate process before bug 970307 has landed. The memory in my local engineering build is not that large. I suppose that there's some flow not sync between PVT and my local build.
Flags: needinfo?(kk1fff)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.