If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Redis error: WRONGTYPE Operation against a key holding the wrong kind of value

RESOLVED FIXED

Status

Hello (Loop)
Server
--
blocker
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: alexis, Assigned: alexis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
This is probably due to the fact we changed how data is handled for room participants.

We were previously using hashes and now are using sets, in order to expire them properly. This change was introduced with bug 1093569.

We haven't detected that on staging due to how we're doing the verification (I think), but on dev. The sentry ticket is for the dev instance, but doesn't really point to which key was holding the wrong value.

https://app.getsentry.com/mozilla/loop/group/50469413/
(Assignee)

Updated

3 years ago
Assignee: nobody → alexis+bugs
(Assignee)

Comment 1

3 years ago
I've been able to reproduce this and it's effectively pre-empting a call to work if it started on 0.14.3 and someone tries to join the conversation using 0.15.0.

We'll solve this with a migration script, to copy over the keys from the old format to the new format. This script should be run just when the new server will be targeted.
(Assignee)

Updated

3 years ago
Blocks: 1120911
(Assignee)

Comment 2

3 years ago
Created attachment 8549245 [details] [review]
link to github PR
Attachment #8549245 - Flags: review?(mathieu)
Attachment #8549245 - Flags: review?(mathieu) → review+
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla-services/loop-server/commit/25e55b738ed8a05e27c6b7fc8f83f943ee3bdf1e
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

3 years ago
https://github.com/mozilla-services/loop-server/commit/25e55b738ed8a05e27c6b7fc8f83f943ee3bdf1e
Blocks: 1123276
You need to log in before you can comment on or make changes to this bug.