[Loop] Invitee name is not shown in history details when he joins as a mobile user

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: isabelrios, Assigned: crdlc)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Room1.1.1_TestRun1][tef-triage])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8548839 [details]
2015-01-14-10-22-16.png

Flame 2.0 device:
Gecko-5f9dc54
Gaia-31d6c94
Loop master version
User A logged in mobile loop client 
User B logged in desktop loop client

1. User A creates and shared a room with User B
2. Both user joins the room
3. When the communication finishes, User A taps on room name to open Room details
4. Then taps on History
5. Check the History details

EXPECTED
History details show when an invitee has joined the room, when the communication was stablished

ACTUAL
When the invitee is a desktop client, when he joins the room instead of the name of the contact as it is saved in the contact list, it is shown Guest.
Please see screenshot attached.
User B is saved in the contact list as: Ire9.
When User A shares the room with him, the name is shown. But, when he joins the room it appears Guest, instead of the name.
(Assignee)

Updated

4 years ago
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
(Assignee)

Comment 1

4 years ago
First:

   This issue is reproducible with two mobiles as well.

Second:

   We have two bugs. The first one is in our app (we are not using the participants parameter). I gonna add a patch to fix this. But regarding to the server side, when the participant is a desktop user, we are receiving this list of participants:

[{"roomConnectionId":"db4405d2-75fa-45f6-80fb-f8c75e9831e0","displayName":"Guest","owner":false},{"roomConnectionId":"c87604d8-1aa1-438c-8adf-5ae142210772","displayName":"crdlc39@gmail.com","account":"crdlc39@gmail.com","owner":true}]

A -> crdlc39@gmail.com (owner and mobile)
B -> Guest (desktop and account crdlc@tid.es)

This means that we are not receiving the account parameter and the displayName is "Guest".

BTW, as I said, this bug is completely reproducible with two mobiles so my patch can be tested under this scenario. Once the server will provide this info, the Firefox Hello should show the name properly.
(Assignee)

Comment 2

4 years ago
Created attachment 8548916 [details] [review]
Github pull request
Attachment #8548916 - Flags: review?(josea.olivera)
Attachment #8548916 - Flags: review?(josea.olivera) → review?(carmen.jimenezcabezas)
(In reply to Cristian Rodriguez (:crdlc) from comment #1)

 But regarding to
> the server side, when the participant is a desktop user, we are receiving
> this list of participants:
> 
> [{"roomConnectionId":"db4405d2-75fa-45f6-80fb-f8c75e9831e0","displayName":
> "Guest","owner":false},{"roomConnectionId":"c87604d8-1aa1-438c-8adf-
> 5ae142210772","displayName":"crdlc39@gmail.com","account":"crdlc39@gmail.
> com","owner":true}]
> 
> A -> crdlc39@gmail.com (owner and mobile)
> B -> Guest (desktop and account crdlc@tid.es)
> 
> This means that we are not receiving the account parameter and the
> displayName is "Guest".
> 
> BTW, as I said, this bug is completely reproducible with two mobiles so my
> patch can be tested under this scenario. Once the server will provide this
> info, the Firefox Hello should show the name properly.

Opened bug 1121861 on Desktop side to handle this
Depends on: 1121861
Severity: normal → critical
Whiteboard: [Room1.1.1_TestRun1] → [Room1.1.1_TestRun1][tef-triage]
Comment on attachment 8548916 [details] [review]
Github pull request

Great job as usual. Thanks!
I left some nits on git
Attachment #8548916 - Flags: review?(carmen.jimenezcabezas) → review+
(Assignee)

Comment 5

4 years ago
in master:

https://github.com/mozilla-b2g/firefoxos-loop-client/commit/d2b3f745f081705935a84db107c9bbd961b31c2c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Loli, Cristian has fixed in this bug the issue between FxOS and FxOS, but not when sharing the URL Room to a Desktop user so I think we should change the bug title to reflect the issue fixed by the patch. What do you think?

Regarding to the scenario FxOS-Desktop I opened bug 1121861 on Desktop side but it seems that's the intended behavior. According to Mark's feedback:

 - If a Room URL is open in a Firefox tab, guest is always used (even if the user is logged in Firefox Browser Hello App).
 - If a Room URL is open via Firefox Browser Hello app the identity used for login in will be used (or guest if user has not logged in)
Flags: needinfo?(lolimartinezcr)
(Reporter)

Updated

4 years ago
Flags: needinfo?(lolimartinezcr)
Summary: [Loop] Invitee name is not shown in history details when he joins as desktop user → [Loop] Invitee name is not shown in history details when he joins as a mobile user
(Assignee)

Comment 7

4 years ago
+1, changed the title, there is not more work to do here
Created attachment 8555781 [details]
20150128_113725.jpg
Tested

Fire E 2.0
Loop 1.1.1/d4d6d37

1. Scenario Mobile-Mobile and it is working.
2. Scenario Desktop-Mobile, according to the commentary: https://bugzilla.mozilla.org/show_bug.cgi?id=1121416#c6 it is running. Please you can see attach image (20150128_113725.jpg).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.